Bug Hunting Session
Bug 124280 - Recent in Start Center always highlighted
Summary: Recent in Start Center always highlighted
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.3.7.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks: Start-Center
  Show dependency treegraph
 
Reported: 2019-03-22 21:17 UTC by Telesto
Modified: 2019-03-25 20:45 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot (40.65 KB, image/jpeg)
2019-03-22 21:18 UTC, Telesto
Details
screenshot from LibreOffice 5.3.7.2 (137.37 KB, image/png)
2019-03-25 19:49 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2019-03-22 21:17:25 UTC
Description:
Recent in Start Center always highlighted

Steps to Reproduce:
1. Open LibreOfficeDev

Actual Results:
Recent always highlighted

Expected Results:
Not highlighted


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.3.0.0.alpha0+
Build ID: bbf9b65f91e8136fa1a2e17960944b8720f5d58e
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-03-15_09:56:33
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: threaded
Comment 1 Telesto 2019-03-22 21:18:00 UTC
Created attachment 150207 [details]
Screenshot
Comment 2 Durgapriyanka 2019-03-25 15:43:15 UTC
I can confirm this in

Version: 6.3.0.0.alpha0+
Build ID: b6b28931435e44aca92b8c0e1659f701e3ed1a87
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-01-30_06:57:04
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 3 Xisco Faulí 2019-03-25 19:49:11 UTC
Created attachment 150284 [details]
screenshot from LibreOffice 5.3.7.2
Comment 4 Xisco Faulí 2019-03-25 19:49:43 UTC
This has been the case since the start center was implemented. Closing as RESOLVED NOTABUG
Comment 5 Telesto 2019-03-25 20:10:02 UTC
(In reply to Xisco Faulí from comment #4)
> This has been the case since the start center was implemented. Closing as
> RESOLVED NOTABUG

Are you sure?

I dont' repro it in
Versie: 5.0.6.3 (x64)
Build ID: 490fc03b25318460cfc54456516ea2519c11d1aa
Locale: nl-NL (nl_NL)

nor in 
4.4.7.2
Comment 6 Telesto 2019-03-25 20:11:25 UTC
Also no repro for
Versie: 5.2.4.2 
Build ID: 3d5603e1122f0f102b62521720ab13a38a4e0eb0
CPU Threads: 4; Versie besturingssysteem:Windows 6.2; UI Render: standaard; 
Locale: nl-NL (nl_NL); Calc: CL
Comment 7 V Stuart Foote 2019-03-25 20:45:41 UTC
Look at work for bug 87697, decision was to have the Recents thumbnails rather than the Templates thumbnails enabled by default.

That has not changed, Recent documents backing window rather than Templates backing window is enabled.

The Cursor focus should open to the Open File button. It does with default profile in master/6.3.0alpha0+.

It behaves correctly with <F6> & <Shift><F6> cycling (since correction of bug 102005)

It behaves correctly with <F10> cycling

It behaves correctly with <Tab> & <Shift><Tab> cycling

It behaves correctly with cursor <Down>, <Right> or <Up>, <Left> within block of gtk elements.

In short--keyboard navigation is correct. And StartCenter GUI should focus to Open File on launch. The Recent Files "selection" is the expected mode.