Bug 124302 - There should be a native built-in "overall" Dark mode option for the user to toggle like MS Word that change everything we look in screen "perfectly visible".
Summary: There should be a native built-in "overall" Dark mode option for the user to ...
Status: RESOLVED DUPLICATE of bug 118320
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.2.2.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-03-24 02:09 UTC by Prabesh432@gmail.com
Modified: 2019-03-27 16:32 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Prabesh432@gmail.com 2019-03-24 02:09:11 UTC
Description:
Right now, we have to change many setting to look like it has a dark mode.
But the fact it, it don't.

I think this is the basic start to give this option.
This is a trending topic and very software developer are providing this.
It would save millions of people's eyes. User like me (student) and other (teacher, professor etc) spent night & day working on this.

Icon which are already dark is not visible when user tries to modify settings.


Actual Results:
Since there is no actual support for dark mode, some icons/options are not clearly visible.

Expected Results:
A clear visible icons would have been night.
A clear visible options for toggling Dark/Night mode would have have been great.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 V Stuart Foote 2019-03-25 12:41:04 UTC

*** This bug has been marked as a duplicate of bug 118320 ***
Comment 2 Xisco Faulí 2019-03-27 11:53:36 UTC
--- Comment #2 from Prabesh432 at gmail.com <PRabesh432 at gmail.com> ---
but the duplicate link denote, it is requested for "Windows".
I hope that counts to Linux too.

Comment lost during the BZ outage -> https://lists.freedesktop.org/archives/libreoffice-bugs/2019-March/176611.html
Comment 3 V Stuart Foote 2019-03-27 13:08:28 UTC
The issue is to follow os/DE provided theme. That is already done on Linux where the user selects their DE provide theme. Or rolls their own--we provide icons to use a ligt/dark theme already. And all other elements (foreground, background, canvas) respond to the DE theme.

Work on HiDPI for UI scaling and use SVG icons already has dev effort. 

In other words NAB nor valid for just Linux builds.

Windows and macOS builds lack correct interface to their "dark" DE themes to support our existing mechanism(s) of theming a dark UI.  Support there likely requires refactoring to be cross platform, and this becomes a dup.
Comment 4 Prabesh432@gmail.com 2019-03-27 16:32:21 UTC
i don't understand anything what u said.

But there should be an option for choosing "Dark mode" in mac/windows and in Linux (specially). Because we no clearly that there is no such option to toggle.