Download it now!
Bug 124354 - Comments no longer show in Calc when mouse hovers over the red dot (steps in comment 9)
Summary: Comments no longer show in Calc when mouse hovers over the red dot (steps in ...
Status: RESOLVED DUPLICATE of bug 120797
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.2.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: KDE GTK3
  Show dependency treegraph
 
Reported: 2019-03-27 13:33 UTC by Owen Savill
Modified: 2019-03-28 17:36 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
sample spreadsheet with comment in cell D11 (7.84 KB, application/vnd.oasis.opendocument.spreadsheet)
2019-03-28 17:08 UTC, Michael Weghorn
Details
Screencast that shows the issue (4.57 MB, video/ogg)
2019-03-28 17:16 UTC, Michael Weghorn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Savill 2019-03-27 13:33:41 UTC
Description:
Comments no longer show in Calc when mouse hovers over the red dot nor if the red dot is clicked. I'm sure it used to. The spreadsheet I'm currently looking at has red dots all over the place and right clicking --> Show Comment and the right click --> Hide Comment is tedious in the extreme.

Steps to Reproduce:
1. Open a spreadsheet with comments
2. Hover over a comment red dot or
3. Click on a comment red dot

Actual Results:
Nothing happens

Expected Results:
The comment should popup


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Comment 1 raal 2019-03-27 19:37:51 UTC
I can not confirm with Version: 6.3.0.0.alpha0+
Build ID: 82463bdde75447d45e0cd6ed9ab579e0e51ea912
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 

Please copy and paste here the contents of your Help - About from your LibreOffice. This allows us to know more about your system.

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the information.
Comment 2 Owen Savill 2019-03-28 10:09:45 UTC
Version: 6.2.2.2
Build ID: 2b840030fec2aae0fd2658d8d4f9548af4e3518d
CPU threads: 8; OS: Linux 4.20; UI render: GL; VCL: kde5; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-GB
Calc: CL

I've tried with a new profile and OpenCL both on and off.

I'm running with KDE / Plasma 5
Comment 3 Owen Savill 2019-03-28 10:19:23 UTC
I don't seem to be able to get hold of 6.3-alpha, please could you supply me a link to download the deb packages?
Comment 4 Vera Blagoveschenskaya 2019-03-28 11:56:24 UTC
Try this one
https://dev-builds.libreoffice.org/daily/master/Linux-rpm_deb-x86_64@86-TDF/
Comment 5 Xisco Faulí 2019-03-28 12:07:00 UTC
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the master build
Comment 6 Owen Savill 2019-03-28 13:30:56 UTC
The dev build crashes on startup with:

KCrash: crashing... crashRecursionCounter = 2
KCrash: Application Name = soffice.bin path = /opt/libreofficedev6.3/program pid = 8064
KCrash: Arguments: /opt/libreofficedev6.3/program/soffice.bin --nocrashhandler 
KCrash: Attempting to start /usr/lib/x86_64-linux-gnu/libexec/drkonqi from kdeinit
sock_file=/run/user/1000/kdeinit5__0
QSocketNotifier: Invalid socket 11 and type 'Read', disabling...
Unable to start Dr. Konqi
Re-raising signal for core dump handling.

drkonqi is installed and the path /usr/lib/x86_64-linux-gnu/libexec is correct so I don't know why it couldn't launch it.
Comment 7 Owen Savill 2019-03-28 13:31:49 UTC
> libreofficedev6.3 --help                                                                                                                                
terminate called after throwing an instance of 'com::sun::star::uno::DeploymentException'
Comment 8 Michael Weghorn 2019-03-28 17:08:05 UTC
Created attachment 150369 [details]
sample spreadsheet with comment in cell D11
Comment 9 Michael Weghorn 2019-03-28 17:16:40 UTC
Created attachment 150372 [details]
Screencast that shows the issue

I can basically confirm this with slightly modified steps (s. attached screencast):

1) open attached spreadsheet which has a comment in cell D11
2) hover with the mouse over the comment -> it is shown
3) move the mouse somewhere else
4) hover over the comment again

Result: comment is NOT shown any more

Reproduced with

Version: 6.3.0.0.alpha0+
Build ID: 28eab5de358631758315a3581e860d6ef533259a
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-US
Calc: threaded

and the same version when using kde5 as well. The same happens with 6.2.2.2 and both, gtk3 and kde5.

This does work as expected (comment shown in both steps 2 and 4) however with this version (from Debian testing repo):

Version: 6.1.5.2
Build ID: 1:6.1.5-1
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3_kde5; 
Locale: en-GB (en_GB.UTF-8); Calc: group threaded
Comment 10 Michael Weghorn 2019-03-28 17:19:16 UTC
Works fine when using the "gen" VCL plugin instead.
Comment 11 Xisco Faulí 2019-03-28 17:36:13 UTC
Regression introduced by https://cgit.freedesktop.org/libreoffice/core/commit/?id=7034311dce663c895577267110baadbec312d491
Dupe of 120797

*** This bug has been marked as a duplicate of bug 120797 ***