Bug 124410 - FORMATTING: Crash in libcuilo.so formatting range containing cells with diagonal borders
Summary: FORMATTING: Crash in libcuilo.so formatting range containing cells with diago...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha1+
Hardware: All All
: high major
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.3.0 target:6.2.3
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2019-03-28 22:13 UTC by Uwe Auer
Modified: 2019-04-03 08:56 UTC (History)
3 users (show)

See Also:
Crash report or crash signature: ["SvxLineItem::GetLine()"]


Attachments
Formatting two cells with diagonal borders cause crsah when formatting range (8.20 KB, application/vnd.oasis.opendocument.spreadsheet)
2019-03-28 22:13 UTC, Uwe Auer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Uwe Auer 2019-03-28 22:13:59 UTC
Created attachment 150384 [details]
Formatting two cells with diagonal borders cause crsah when formatting range

This bug was filed from the crash reporting server and is br-cca9c0fc-7f2e-4fcf-a7cf-8ff017d84363.
=========================================

Crash in libcuilo.so formatting range containing cells with diagonal borders (see Uploaded TestCase.ods file)

Reproducibility: Always

Steps to reproduce (see also attachment)
1) Open empty spreadsheet in Calc
2) Format one or more cells with a diagonal border
3) Select an arbitrary range containing cell(s) from step 2.
4) Right click and select "Format Cells"

=> Crash occurs

Configuration of reporter system
Version: 6.2.2.2
Build-ID: 2b840030fec2aae0fd2658d8d4f9548af4e3518d
CPU-Threads: 8; BS: Linux 4.12; UI-Render: GL; VCL: kde5; 
Gebietsschema: de-DE (de_DE.UTF-8); UI-Sprache: de-DE
Calc: threaded

Another report in https://ask.libreoffice.org/de/question/188471/calc-seit-lo-62-fehler-bei-diagonalen-linien-in-zellen/
Comment 1 Xisco Faulí 2019-03-29 00:11:44 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=229483707c3ccb48d008d37f856bbeb6df199a90

author	Caolán McNamara <caolanm@redhat.com>	2018-09-03 16:06:49 +0100
committer	Caolán McNamara <caolanm@redhat.com>	2018-09-05 13:36:35 +0200
commit	229483707c3ccb48d008d37f856bbeb6df199a90 (patch)
tree	c202bfb4777a66e6095fc971e317794f92399b4a
parent	59b9fc4776940863d905de14e25d74421f7de603 (diff)
weld SvxBorderTabPage

Bisected with: bibisect-linux64-6.2

Adding Cc: to Caolán McNamara
Comment 2 Commit Notification 2019-03-29 13:43:43 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/6c29dbb7a1c3a04f3cbaa3dd720db482755538d7%5E%21

Resolves: tdf#124410 crash cell border page with diagonal borders

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Caolán McNamara 2019-03-29 13:53:48 UTC
backport to 6-2 in gerrit
Comment 4 Commit Notification 2019-03-29 19:15:58 UTC Comment hidden (off-topic)
Comment 5 Caolán McNamara 2019-03-29 19:22:42 UTC
(In reply to Commit Notification from comment #4)
> Caolán McNamara committed a patch related to this issue.
> It has been pushed to "master":
> 
This piece should have been for bug 124386
Comment 6 Xisco Faulí 2019-03-30 15:48:49 UTC
Verified in

Version: 6.3.0.0.alpha0+
Build ID: 107fd82751c35818152eabd45bdf882972d3c100
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Caolán, thanks for fixing this issue!!
Comment 7 Commit Notification 2019-03-30 15:50:25 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/685c847a00ee653bd0c2bd42a7f7f866885896e8%5E%21

Resolves: tdf#124410 crash cell border page with diagonal borders

It will be available in 6.2.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Uwe Auer 2019-04-01 08:20:04 UTC
Feedback -  Test by reporter

Version tested:

Version: 6.2.4.0.0+
Build-ID: c3eeb421526f284419e90d2c4c4da5b0d7bbcc0e
CPU-Threads: 4; BS: Linux 4.12; UI-Render: Standard; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:libreoffice-6-2, Time: 2019-03-31_10:03:42
Gebietsschema: de-DE (de_DE.UTF-8); UI-Sprache: de-DE
Calc: threaded

Result: Fixed

Thanks
Comment 9 Commit Notification 2019-04-01 16:14:50 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2-3":

https://git.libreoffice.org/core/+/63f8f7c852822a68923092c239cff35a99f448b9%5E%21

Resolves: tdf#124410 crash cell border page with diagonal borders

It will be available in 6.2.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Xisco Faulí 2019-04-03 08:56:51 UTC
*** Bug 124496 has been marked as a duplicate of this bug. ***