Download it now!
Bug 124439 - I have been encountering issues while saving in Google Drive.
Summary: I have been encountering issues while saving in Google Drive.
Status: RESOLVED DUPLICATE of bug 101630
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.0.7.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-03-29 18:34 UTC by Abhisek Bhattacharya
Modified: 2019-03-29 22:02 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Abhisek Bhattacharya 2019-03-29 18:34:46 UTC
Description:
Upon using 'Open Remote' or 'Save Remote' option in LibreOffice, I click on 'Add Service'; then in 'Type' "Google Drive", I enter my 'User', 'Password', check 'Remember Password' and click 'OK'. After a few seconds, the system asks for 'Authentication Code' and wants me to 'Enter the 6 digit PIN'. However, no such PIN is sent to my mobile/email. I tried by enabling/disabling Two-factor authentication in my Google Account, using 6 digit pin generated by the Google Authenticator app, but to no avail. Moreover, only the Google Authenticator app generates random 6 digit pin; for security verification, Google generates only 4 or 8 digit pin. I think this is a bug/problem that should be addressed.

Steps to Reproduce:
1. File-Open Remote or Save Remote.
2. In Service, click Add Service.
3. In 'Type' Google Drive, type User, Password, check Remember Password & click OK.
4. After few seconds, a box opens asking for Authentication Code, and want the 6-digit PIN.

Actual Results:
No such PIN is sent to my mobile/email, even after repeated attempts. I tried to do the same in both my Linux (Ubuntu 18.04.2 LTS) and Windows 10 Home OS PCs but the bug remains.

Expected Results:
The software should have directly signed onto the Google Drive, when User & Password is entered; else it should have been paired to work properly with the Google Authentication system (viz. the Google Authenticator app).


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 6.0.7.3
Build ID: 1:6.0.7-0ubuntu0.18.04.2
CPU threads: 2; OS: Linux 4.18; UI render: default; VCL: gtk3; 
Locale: en-IN (en_US.UTF-8); Calc: group
Comment 1 Oliver Brinzing 2019-03-29 22:02:54 UTC
i think this issue is a duplicate of 
Bug 101630 - Google Drive two-factor authentication (2FA) not working again

if you disagree, please have a look at the referenced issues 
-> Bug 101630 -> See Also

*** This bug has been marked as a duplicate of bug 101630 ***