Bug 124447 - Draw does not allow precise sizes of objects
Summary: Draw does not allow precise sizes of objects
Status: RESOLVED DUPLICATE of bug 99711
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
6.1.5.2 release
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-03-30 15:41 UTC by Leos Pohl
Modified: 2019-03-30 17:19 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Leos Pohl 2019-03-30 15:41:18 UTC
Description:
Version: 6.1.5.2
Build ID: 90f8dcf33c87b3705e78202e3df5142b201bd805
CPU threads: 8; OS: Mac OS X 10.14.4; UI render: default; 
Locale: en-US (cs_CZ.UTF-8); Calc: group threaded

MWE:
Open Draw, set page size to A4 and in settings, LibreOffice Draw->General, units = mm

When you draw a shape (rectangle) and set its dimensions in the toolbar window, the dimensions are set incorrectly. Draw changes the input values.

This is a serious issue if one wants to draw precise shapes, for non-precise shapes it does not matter, but then one does not need two decimal places for mm when setting the size.

Steps to Reproduce:
Draw a rectangle, from the right side toolbar select Position and Size, set size of the rectangle to be 30x40 mm, deselect the rectangle, select the rectangle again and the boxes show different sizes than 30x40, in my case 29.97 and 39.88. This happens if you draw a circle and want to set a particular size, it does not work either, Draw selects the diameter for you. If i do this to a circle which I want to have diameter 55mm Draw decides that the diameter will be 55.12mm

Actual Results:
The size is set to 29.97 and 39.88 mm

Expected Results:
The size is supposed to be 30 and 40 mm


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 V Stuart Foote 2019-03-30 17:19:30 UTC
How are you able to "set its dimensions in the toolbar window". The Drawing toolbar, normally docked vertical to left edge, has no entry for object size.

We'll assume you mean the Sidebar -> Properties -> Position & Size content panel?

And this is a dupe of a known issue, bug 99711

Otherwise a screen clip please.

*** This bug has been marked as a duplicate of bug 99711 ***