Download it now!
Bug 124506 - No LibreOffice component program icons display in KDE Plasma 5 Task Manager in the main Panel.
Summary: No LibreOffice component program icons display in KDE Plasma 5 Task Manager i...
Status: RESOLVED DUPLICATE of bug 104235
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.0.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2019-04-02 16:38 UTC by Kelton Newman
Modified: 2019-04-03 14:55 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kelton Newman 2019-04-02 16:38:23 UTC
Description:
In the KDE Plasma 5 Panel resides the Task Manager

In the Task Manager, icons for running programs appear.

When LibreOffice (version: 6.2.2.2; Build ID:  2b840030fec2aae0fd2658d8d4f9548af4e3518d) is running, a generic X-application icon appears in the Task Manager instead of the icon for the component of LibreOffice (such as Writer, Calc, Impress, etc.) that is running.

When the component program of LibreOffice is starting up, the appropriate icon appears in the Task Manager for about ½ a second.  But that icon disappears and the generic X-icon application replaces it.

Steps to Reproduce:
1. Turn on computer
2. Log in to user account
3. Run (any component) of LibreOffice (Start Center, Writer, Impress, Calc, Base, etc.)

Actual Results:
A generic X-application icon represents the running component of LibreOffice in the Task Manager on the main Panel.

Expected Results:
A LibreOffice component-program's icon should represent the running component of LibreOffice in the Task Manager on the main Panel.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 6.2.2.2
Build ID: 2b840030fec2aae0fd2658d8d4f9548af4e3518d
CPU threads: 4; OS: Linux 5.0; UI render: default; VCL: kde5; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Kelton Newman 2019-04-02 23:28:29 UTC
@ ajlittoz

I'm not sure where to answer your question.  This may be the wrong spot.  Forgive me, I'm not a techie.

I use a distro called PCLinuxOS (2019.03).  To my knowledge, there's no official distro release level, but March 2019 was the most recent date that a new ISO was made available ... and I did do a clean install from that ISO.  Note that the same problem I'm having now with the icons was also present before the clean install.
Comment 2 Michael Weghorn 2019-04-03 14:55:48 UTC
This sounds very much like bug 104235, which has been fixed for LibreOffice 6.2.3.

I'm therefore closing this bug report as a duplicate. Should the issue still occur with LibreOffice 6.2.3 or newer, please reopen.

*** This bug has been marked as a duplicate of bug 104235 ***