Bug 124512 - FILEOPEN DOCX: Document content is misssing
Summary: FILEOPEN DOCX: Document content is misssing
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: DOCX
  Show dependency treegraph
 
Reported: 2019-04-03 02:10 UTC by Andrew Bromwich
Modified: 2019-04-03 10:49 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Document only renders first few lines in LO (39.22 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-04-03 02:19 UTC, Andrew Bromwich
Details
Problem document rendered in LO nightly (28.28 KB, image/png)
2019-04-03 02:20 UTC, Andrew Bromwich
Details
Problem document rendered in Word 16 (228.31 KB, image/png)
2019-04-03 02:20 UTC, Andrew Bromwich
Details
Problem document rendered in Mac Preview (52.56 KB, image/png)
2019-04-03 02:21 UTC, Andrew Bromwich
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Bromwich 2019-04-03 02:10:20 UTC
Description:
Test document contains multiple pages.
Content is displayed as expected in Word (v16)
Content is displayed as expected in Mac Preview
However when opened in LO the document only shows part of the first page.

Issue has been reproduced in LO v5.4.5.1 as well as the current nightly build

Steps to Reproduce:
1. Open "Partial-contents-displayed.docx"
2. Note that only content up to '.. with text below this missing' is displayed


Actual Results:
Only the content up to '.. with text below this missing' is displayed

Expected Results:
Display the remainder of the content on the first page "Thanks for looking", as well as the content on subsequent pages


Reproducible: Always


User Profile Reset: Yes



Additional Info:
If the problem document is saved as an ODT in Word, it does render as expected in LO.

See attached screenshots of the document rendered with various document viewers (Word 16, LO nightly and Mac preview)
Comment 1 Andrew Bromwich 2019-04-03 02:19:16 UTC
Created attachment 150488 [details]
Document only renders first few lines in LO
Comment 2 Andrew Bromwich 2019-04-03 02:20:06 UTC
Created attachment 150489 [details]
Problem document rendered in LO nightly
Comment 3 Andrew Bromwich 2019-04-03 02:20:33 UTC
Created attachment 150490 [details]
Problem document rendered in Word 16
Comment 4 Andrew Bromwich 2019-04-03 02:21:01 UTC
Created attachment 150491 [details]
Problem document rendered in Mac Preview
Comment 5 Dieter 2019-04-03 06:44:38 UTC
I confirm this with

Version: 6.2.2.2 (x64)
Build-ID: 2b840030fec2aae0fd2658d8d4f9548af4e3518d
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: threaded

in comparison with Word 2016