Bug 124513 - Calc: Unable to reference cells in another workbook using mouse from Function Wizard
Summary: Calc: Unable to reference cells in another workbook using mouse from Function...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.2.2 release
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.5.0 target:6.4.0.1 target:6....
Keywords: bibisected, bisected, regression
: 126651 126988 (view as bug list)
Depends on:
Blocks: Function-Vlookup Regressions-Dialog-Tunneling
  Show dependency treegraph
 
Reported: 2019-04-03 02:18 UTC by peter
Modified: 2022-02-22 07:09 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
printscreen (85.16 KB, image/png)
2019-05-03 17:30 UTC, raal
Details
Screencast of using wizard with VLOOKUP (849.92 KB, image/gif)
2019-12-12 06:00 UTC, Mike Kaganski
Details
Screen cast on 5.4 (1.45 MB, image/gif)
2019-12-12 06:21 UTC, Mike Kaganski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description peter 2019-04-03 02:18:49 UTC
Description:
1. more file can't use vlookup function;
2. one file ,more  sheet  is ok;
3. use  lib 6.0,6.1,6.2,6.2.3 ;
4. on  one  is ok
5. I report  this  bug  on bbs on  last  month , but  no one  response  this question;

1.  pls use  two  excel  file,include(xls,ods,xlsx);
2.  winodows  system(windows 7 64bit, professional os);
3.  CPU:I5,memory: 8G, hardisk:500 GB;

Steps to Reproduce:
1. use  two excel;
2. use vlookup  function ;
3 can't  use mouse draw ;

Actual Results:
can't use

Expected Results:
ms  office


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Comment 1 Roman Kuznetsov 2019-04-03 08:21:40 UTC
please add more clear steps for repro
Comment 2 Xisco Faulí 2019-04-03 14:04:11 UTC
Thank you for reporting the bug. Please attach a sample document, as this makes it easier for us to verify the bug. 
(Please note that the attachment will be public, remove any sensitive information before attaching it. 
See https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F for help on how to do so.)

I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested document is provided.
Comment 3 mulla.tasanim 2019-04-06 05:50:55 UTC
Thank you for reporting the bug. 
Unfortunately without clear steps to reproduce it, we cannot track down the origin of the problem. 
Please provide a clearer set of step-by-step instructions on how to reproduce the problem.
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested information is provided.
Comment 4 Darek 2019-04-24 11:07:12 UTC
I think I have a similar problem with the function wizard
Description:
1. Selecting the vlookup function from the wizard.
2. Indicating the matrix field to the sheet in another opened file.
3. The function wizard does not transfer a range of cells from a sheet from another file (no reference or link to another file).
Comment 5 raal 2019-05-03 17:15:18 UTC
Confirm with 6.3, Linux, regression
Comment 6 raal 2019-05-03 17:30:06 UTC
This seems to have begun at the below commit.
Adding Cc: to Henry Castro ; Could you possibly take a look at this one?
Thanks
 d69919320545a15351976d49883332bee16dc37d is the first bad commit
commit d69919320545a15351976d49883332bee16dc37d
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Fri Mar 16 21:26:29 2018 +0100

    source sha:009d2756b1678477ec23d5647bd5004c4bff3a62

author	Henry Castro <hcastro@collabora.com>	2018-03-15 14:23:48 -0400
committer	Henry Castro <hcastro@collabora.com>	2018-03-16 20:58:50 +0100
commit 009d2756b1678477ec23d5647bd5004c4bff3a62 (patch)
tree c1ad3f7de8bb95085b38ceff13a8064fa19f2089
parent 8a8663a49b6d2ba297587c730860cc8ca9d139da (diff)
lokdialog: do not lock events when opened ScFilter Dialog
Comment 7 raal 2019-05-03 17:30:44 UTC
Created attachment 151165 [details]
printscreen
Comment 8 raal 2019-08-02 14:07:50 UTC
*** Bug 126651 has been marked as a duplicate of this bug. ***
Comment 9 astrel 2019-08-09 11:06:00 UTC
I have a same problem with the function wizard
Description:
1. Selecting the vlookup function from the wizard.
2. Indicating the matrix field to the sheet in another opened file.
3. The function wizard does not transfer a range of cells from a sheet from another file.Сhecked in lib 6.2.x-6.3.0.4
Comment 10 Xisco Faulí 2019-11-21 12:29:44 UTC
Dear Henry Castro,
This bug has been in ASSIGNED status for more than 3 months without any
activity. Resetting it to NEW.
Please assign it back to yourself if you're still working on this.
Comment 11 Xisco Faulí 2019-11-21 12:30:33 UTC
@Caolán, I thought you might be interested in this issue...
Comment 12 Commit Notification 2019-11-22 10:55:00 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/f31d36966bceb90e261cbecd42634bde4448d527

tdf#124513 let wizard reappear on tabbing back to document

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2019-11-22 13:34:08 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/ebba06b785c87e6a310a523fa9570449d3986cd7

tdf#124513 let wizard reappear on tabbing back to document

It will be available in 6.4.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2019-11-26 14:59:10 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/e5f74d20c2b72b107fe719cc888d779f17e5d57c

tdf#124513 Allow to use multiple Formula dialog instances

It will be available in 6.3.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2019-11-26 23:43:57 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/95846782231096345e9a09b3fa35355316ef50fe

tdf#124513 let wizard reappear on tabbing back to document

It will be available in 6.3.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Caolán McNamara 2019-11-27 09:12:29 UTC
this should work now
Comment 18 Darek 2019-11-27 18:40:55 UTC
I confirm in new version the problem is solved.

Version: 6.4.0.0.beta1+
Build ID: 3bd1b85cdc00456e35d286d3d76ffd7b36c5e03e
CPU threads: 4; OS: Linux 5.3; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:libreoffice-6-4, Time: 2019-11-26_02:21:24
Comment 19 Commit Notification 2019-12-01 20:24:33 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-3-4":

https://git.libreoffice.org/core/commit/1b4c9908887b5260033b431d6c5e4a9c10b9ee53

tdf#124513 let wizard reappear on tabbing back to document

It will be available in 6.3.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 20 astrel 2019-12-11 03:26:10 UTC
The problem is not solved

Версия: 6.3.4.2 (x86)
ID сборки: 60da17e045e08f1793c57c00ba83cdfce946d0aa
Потоков ЦП: 4; ОС:Windows 10.0; Отрисовка ИП: по умолчанию; VCL: win; 
Локаль: ru-RU (ru_RU); Язык интерфейса: ru-RU
Calc: threaded
Comment 21 peter 2019-12-11 04:20:44 UTC Comment hidden (no-value)
Comment 22 Xisco Faulí 2019-12-11 08:31:13 UTC
@astrel, @peter,
could you please explain the steps to reproduce it ?
Comment 23 peter 2019-12-12 04:20:21 UTC
Dear :
    step 1 :

        please create  2  excel files ;


    step 2:

        use the  function: vlooup ;


      pls try  it , the test  is very  easy , u can found the error ;


     thank  you very much!
Comment 24 astrel 2019-12-12 05:50:16 UTC
To play, be sure to use the function wizard and mouse !!!!
Comment 25 Mike Kaganski 2019-12-12 06:00:38 UTC
Created attachment 156501 [details]
Screencast of using wizard with VLOOKUP

Confirming that the original problem (however poor the original "description" were) is still not fixed.
Comment 26 Mike Kaganski 2019-12-12 06:14:51 UTC
And just to be clear: this has never worked, including LO 3.3, and AOO. It's an inherited limitation (inability to select a range from another document using the wizard and mouse), and the regression that was tracked here starting from comment 5 is a different problem (thanks for fixing that), but it does *not* address the original request for enhancement.

Since the confusion happened here, it might be a good idea to close this one (as tracking the regression part), and file a new one for the original problem.
Comment 27 Mike Kaganski 2019-12-12 06:21:44 UTC
Created attachment 156502 [details]
Screen cast on 5.4

Oh excuse me for the statement that this has never worked. It did, when the files are saved; please see how this worked in 5.4.
Comment 28 astrel 2019-12-12 06:39:14 UTC
      Mike Kaganski,thank you so much for your help!
 This problem started with L.O. 6.1.x.x.
Comment 29 Mike Kaganski 2019-12-12 06:57:35 UTC
Whatever the decision is wrt keeping the bug here, or moving into a new issue: the original problem is a regression after https://gerrit.libreoffice.org/plugins/gitiles/core/+/009d2756b1678477ec23d5647bd5004c4bff3a62
Comment 30 Xisco Faulí 2019-12-12 08:41:50 UTC
*** Bug 126988 has been marked as a duplicate of this bug. ***
Comment 31 peter 2019-12-13 08:27:05 UTC
Dear Xisco Faul:

The next version  6.4!

can  we  solved  this error?

Thank you  very much!!
Comment 32 astrel 2019-12-25 02:06:42 UTC
The problem is solved! 

Версия: 6.4.0.1 (x86)
ID сборки: 1b6477b31f0334bd8620a96f0aeeb449b587be9f
Потоков ЦП: 4; ОС: Windows 10.0 Build 18362; Отрисовка ИП: по умолчанию; VCL: win; 
Локаль: ru-RU (ru_RU); Язык интерфейса: ru-RU
Calc: threaded

and 6.4.0.1 (x64)
Comment 33 peter 2019-12-26 02:05:32 UTC
Dear :

    I used  the  new version  6.4.0.1  test  this bug;
   
    but  sorry , The  bug is not solved !

   pls  try again , tks!       
     

     My   computer:

     1. OS: windows 7;
     2. language: chinese;
     3. liberorffice version:6.4.0.1(X64)
Comment 34 Justin L 2022-02-22 07:05:19 UTC
Based on my attempt to follow the reproduction steps, this is working. (Ubuntu 20.04, LO 7.2.)

Although there is one claim that it still is not working (in 2019), others who are invested in this bug report say that it is working since 6.4.

Since this bug has been silent for over two years, I'll mark it as worksforme. Because this bug is so messy, anyone who disagrees should open a new bug report and clearly explain how to still reproduce.
Comment 35 Mike Kaganski 2022-02-22 07:09:56 UTC
Comment on attachment 156501 [details]
Screencast of using wizard with VLOOKUP

Indeed, attachment 156501 [details] shows two unsaved documents. Referencing an external document without a storage is not possible.