Bug Hunting Session
Bug 124533 - Unable to save network file from KDE Plasma
Summary: Unable to save network file from KDE Plasma
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.1.0.3 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: KDE Network
  Show dependency treegraph
 
Reported: 2019-04-03 18:14 UTC by Maverick
Modified: 2019-04-08 17:11 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Maverick 2019-04-03 18:14:16 UTC
Description:
In KDE Plasma 5.12.6 (openSUSE Leap 15.0) , i get to a network shared folder (from a windows share), open a calc file, fill a cell, save it and close the file.

When i open it, all changes i made are gone!

This happened since LibreOffice 6.1 and keeps going in 6.2 (i guess its from the moment libreoffice-kde4 package was drop...)

Steps to Reproduce:
1.Access a network windows share, and open a shared Calc file
2.make changes, save it and close it
3.reopen the file


Actual Results:
Changes made are gone

Expected Results:
Changes made should be present


Reproducible: Always


User Profile Reset: No



Additional Info:
i guess this happens from the moment that libreoffice-kde4 package was drop
Comment 1 Michael Weghorn 2019-04-05 22:01:43 UTC
Thanks for your report.

(In reply to Maverick from comment #0)
> 1.Access a network windows share, and open a shared Calc file

How exactly are you opening the file (e.g. double-clicking from the Dolphin file manager, using "File" -> "Open" from within LibreOffice)?

If you're opening the file from the file manager: What path/location does it show for the directory the file is in? Is that something that starts with 'smb://'?

I've set the bug status to NEEDINFO. Please set back to UNCONFIRMED once you have provided the requested information.
Comment 2 Maverick 2019-04-08 09:17:24 UTC
(In reply to Michael Weghorn from comment #1)
> Thanks for your report.
> 
> (In reply to Maverick from comment #0)
> > 1.Access a network windows share, and open a shared Calc file
> 
> How exactly are you opening the file (e.g. double-clicking from the Dolphin
> file manager, using "File" -> "Open" from within LibreOffice)?
> 
> If you're opening the file from the file manager: What path/location does it
> show for the directory the file is in? Is that something that starts with
> 'smb://'?
> 
> I've set the bug status to NEEDINFO. Please set back to UNCONFIRMED once you
> have provided the requested information.

hi Michael

I'm using double click from Dolphin file manager.

The path does start 'smb://'

I must add, however, that this bug does not exist in Tumbleweed and so, it is my hope that next openSUSE 15.1 (due to be released at the end of May) will have it fixed as well. But i'm not sure about it...
Comment 3 Michael Weghorn 2019-04-08 15:19:19 UTC
(In reply to Maverick from comment #2)
> I'm using double click from Dolphin file manager.
> 
> The path does start 'smb://'
> 
> I must add, however, that this bug does not exist in Tumbleweed and so, it
> is my hope that next openSUSE 15.1 (due to be released at the end of May)
> will have it fixed as well. But i'm not sure about it...

Thanks for the update.
This sounds like an issue that has been fixed in KIO (i.e. outside of LibreOffice) by this commit:
https://cgit.kde.org/kio.git/commit/?id=820f622e86bb0b7d44a39a3f90f84c99736b30c7

The bug report in KDE's Bugzilla is this one:
https://bugs.kde.org/show_bug.cgi?id=397742

I'm therefore closing this as NOTOURBUG. Feel free to reopen in case the problem reappears with a more recent version of Plasma/KIO.
Comment 4 Maverick 2019-04-08 16:45:27 UTC
OK! Thanks for clarifying that Michael.

Can you please explain if LO already supports KIO Natively (bug #119429)?

The bug is closed but i think LO does not support it yet...
Comment 5 Michael Weghorn 2019-04-08 17:11:06 UTC
LibreOffice doesn't support KIO natively yet, there's also bug 70712 about this.