Bug 124590 - DPI of exported PNG images is never what I set it to
Summary: DPI of exported PNG images is never what I set it to
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
6.2.0.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Graphics-Export
  Show dependency treegraph
 
Reported: 2019-04-07 15:58 UTC by Francis
Modified: 2020-03-24 02:48 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sample image I exported at 600 DPI (2.5 x 3.5 Inches) (983.88 KB, image/png)
2019-06-05 21:20 UTC, Francis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Francis 2019-04-07 15:58:05 UTC
Description:
I have some trading cards I was putting together with a draw template I created that is 2.5 inches wide by 3.5 inches tall. Whenever I try to export the images as png files at 600 dpi I end up with something that is 1501 by 2102 pixels and the dpi of the created image file is always something odd like 600.507 instead of the 600 I set it to be in the export options.

Steps to Reproduce:
1.create an image in draw
2.export it as a png at 600 dpi
3.check the file size in pixels and the dpi

Actual Results:
The dpi of the exported png is an odd fraction like 600.507

Expected Results:
It should be the 600 dpi I set it to.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 6.2.0.3 (x64)
Build ID: 98c6a8a1c6c7b144ce3cc729e34964b47ce25d62
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 1 Xisco Faulí 2019-06-05 15:36:52 UTC
Thank you for reporting the bug. Please attach a sample document, as this makes it easier for us to verify the bug. 
(Please note that the attachment will be public, remove any sensitive information before attaching it. 
See https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F for help on how to do so.)

I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested document is provided.
Comment 2 Francis 2019-06-05 21:20:39 UTC
Created attachment 151949 [details]
Sample image I exported at 600 DPI (2.5 x 3.5 Inches)
Comment 3 QA Administrators 2019-06-06 02:55:40 UTC Comment hidden (obsolete)
Comment 4 Buovjaga 2019-08-25 15:47:20 UTC
(In reply to Francis from comment #2)
> Created attachment 151949 [details]
> Sample image I exported at 600 DPI (2.5 x 3.5 Inches)

This is the exported result. We need the source Draw file (odg)
Comment 5 QA Administrators 2020-02-22 02:50:53 UTC Comment hidden (obsolete)
Comment 6 QA Administrators 2020-03-24 02:48:46 UTC
Dear Francis,

Please read this message in its entirety before proceeding.

Your bug report is being closed as INSUFFICIENTDATA due to inactivity and
a lack of information which is needed in order to accurately
reproduce and confirm the problem. We encourage you to retest
your bug against the latest release. If the issue is still
present in the latest stable release, we need the following
information (please ignore any that you've already provided):

a) Provide details of your system including your operating
   system and the latest version of LibreOffice that you have
   confirmed the bug to be present

b) Provide easy to reproduce steps – the simpler the better

c) Provide any test case(s) which will help us confirm the problem

d) Provide screenshots of the problem if you think it might help

e) Read all comments and provide any requested information

Once all of this is done, please set the bug back to UNCONFIRMED
and we will attempt to reproduce the issue. Please do not:

a) respond via email 

b) update the version field in the bug or any of the other details
   on the top section of our bug tracker

Warm Regards,
QA Team

MassPing-NeedInfo-FollowUp