Download it now!
Bug 124615 - FILEOPEN: DOC - rotated images not rotated on import
Summary: FILEOPEN: DOC - rotated images not rotated on import
Status: RESOLVED DUPLICATE of bug 116371
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-04-08 16:19 UTC by Luke
Modified: 2019-04-15 12:49 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Native Word .doc with image rotated 75 degrees clockwise (31.00 KB, application/msword)
2019-04-08 16:19 UTC, Luke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luke 2019-04-08 16:19:08 UTC
Created attachment 150615 [details]
Native Word .doc with image rotated 75 degrees clockwise

With Bug 70838 fixed, we now correctly export image rotation values. However, the importer does not read these values. 

Steps to Reproduce:
1. Open attachment 88076 [details]
2. Save as .doc
3. Close and Open .doc

Expected:
1. Image and Size -> Rotation
2. Rotation Angle = 44.99 / 45

Image rotated 
1. Rotation Angle = 0

Note: If opened in Word, the image is correctly rotated.
Comment 1 raal 2019-04-08 17:12:32 UTC
confirm with Version: 6.3.0.0.alpha0+
Build ID: 31ac398cfa30694b18240d31df17a58d699b5bf6
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: cs-CZ (cs_CZ.UTF-8); UI-Language: en-US

*** This bug has been marked as a duplicate of bug 116371 ***