Bug 124617 - Add Icons to toolbars in AvailableToolbars like the Text Formula field's Formula button
Summary: Add Icons to toolbars in AvailableToolbars like the Text Formula field's Form...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Icon-Request
  Show dependency treegraph
 
Reported: 2019-04-08 21:53 UTC by andreas_k
Modified: 2019-04-10 07:54 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
AvailableToolbars Formular show an icon, all other toolbars not. (78.90 KB, image/jpeg)
2019-04-08 21:53 UTC, andreas_k
Details

Note You need to log in before you can comment on or make changes to this bug.
Description andreas_k 2019-04-08 21:53:41 UTC
Created attachment 150617 [details]
AvailableToolbars Formular show an icon, all other toolbars not.
Comment 1 V Stuart Foote 2019-04-09 05:21:57 UTC
Not sure we'd be able or want to assign icons to the Toolbars where the selection status is radio button/checkbox. @Maxim?

If so, you'd have to design them all, in all themes.

Otherwise the Formula bar <F2> is not a regular toolbar structure [1]. I think its icon on the submenu is an exception drawn from the toolbox. But then its entry probably does not belong on the View -> Toolbars menu anyhow.

Because when present the Text Formula field responds when accessed via the Edit -> Fields menu entry. And it should probably have an entry on the Insert -> Field submenu-- maybe as "Text Formula"--for creating the field.  And, it is also unique in that the field does not show up in the Fields dialog. It is a weird object, with a weird set of controls.

=-ref-=
[1] https://opengrok.libreoffice.org/xref/core/sw/source/uibase/ribbar/inputwin.cxx?r=d8037ae1#61
Comment 2 Roman Kuznetsov 2019-04-09 20:58:05 UTC
Andreas, do you have some example icons for toolbars? How do you see it?

I think it just don't need.

And this Formula "toolbar" need delete from menu
Comment 3 Heiko Tietze 2019-04-10 07:45:56 UTC
(In reply to V Stuart Foote from comment #1)
> Not sure we'd be able or want to assign icons to the Toolbars where the
> selection status is radio button/checkbox.

We talked about this recently at bug 123261 where the decision was made to have icons next to radio buttons. Personally, I dislike too many icons because the UI becomes more noisy; in particular with monochrome icons nothing pops-out and I have to concentrate on the actual label away from the limelighting icons.
Comment 4 andreas_k 2019-04-10 07:53:10 UTC
Thanks for the feedback. About remove the Formula toolbar, I open a new bug report Bug 124642.