Bug Hunting Session
Bug 124634 - Display all search results together with context in navigation bar
Summary: Display all search results together with context in navigation bar
Status: RESOLVED DUPLICATE of bug 95405
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.2.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Find-Search Navigator
  Show dependency treegraph
 
Reported: 2019-04-09 22:32 UTC by Trukas
Modified: 2019-04-10 08:21 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Trukas 2019-04-09 22:32:29 UTC
Description:
To find text in a document, currently one has to use the "find bar".
The find bar will position the cursor at the first occurrence of the search result.

If there are many results, the only way to find the correct one is to look at all results sequentially using "Find Next".

There is no way to see all results together for quick browsing.

I suggest adding the list of search results together with the line where they occur to the navigation pane so that multiple results can be seen at a glance before selecting the correct one.

This improvement will make navigation much quicker and allows to see all lines containing a search term (e.g. TODO) at the same time.

Steps to Reproduce:
Open new document
Enter multiple lines of text :

... insert lots of text and pagebreaks...
TODO: do one thing
... insert lots of text and pagebreaks...
TODO: do another thing
... insert lots of text and pagebreaks...
TODO: do even more

Search using find bar "ctrl+F todo"

Actual Results:
The find bar appears at the bottom of the writer window and the first occurrence of "TODO" is highlighted in the text

Expected Results:
Show all occurrences of "TODO: in the navigation pane on the side together with the full line that contains the results.

Clicking on a result will jump to the occurrence in the document.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Searching a document by jumping through each occurrence is very inefficient and time consuming when there are many hits.

Microsoft Word has a navigation pane that shows all of the search results together with the context around them. By clicking on a result one jumps to the position in the document.

Here is a picture of the Word navigation pane
https://www.dummies.com/wp-content/uploads/493775.image0.jpg

https://www.dummies.com/software/microsoft-office/word/how-to-find-text-in-word-2016/

This pane makes searching far more efficient.
Comment 1 Heiko Tietze 2019-04-10 08:21:50 UTC
The use case is pretty clear - excellent report, thanks a lot - but the topic is not new. It's discussed under the terms Sidebar and Deck [1] (a special node in the Navigator (F5) might not so well suited) in bug 95405 and I resolve your ticket as duplicate. Many thanks for reporting anyway.

[1] https://wiki.documentfoundation.org/Design/SideBar

*** This bug has been marked as a duplicate of bug 95405 ***