Download it now!
Bug 124657 - Some punctuations are rendered inconsistent with CJK text
Summary: Some punctuations are rendered inconsistent with CJK text
Status: RESOLVED DUPLICATE of bug 66791
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: CJK
  Show dependency treegraph
 
Reported: 2019-04-10 14:48 UTC by Volga
Modified: 2019-05-13 07:11 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Test ODT file (9.91 KB, application/vnd.oasis.opendocument.text)
2019-04-10 14:50 UTC, Volga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Volga 2019-04-10 14:48:31 UTC
Description:
Some characters as quotemarks and interpuncts looks so different with 

Steps to Reproduce:
1. Open my attached ODT file

Actual Results:
1st line: “ (U+201C) is rendered with Source Han Serif SC, ” (U+201D) is rendered with Liberarion Serif.
2nd line: “ (U+201C) is rendered with Liberarion Serif, ” (U+201D) is rendered with Source Han Serif SC.
3rd line: First · (U+00B7) is rendered with Source Han Serif SC, second · is rendered with Liberarion Serif.
4th line: First ‧ (U+2027) is rendered with Source Han Serif SC, second ‧ is rendered with fallback font.

See this image: https://i.imgur.com/12UQx4m.png

Expected Results:
If Weiter can set the language of page at the page level, and set the language as Chinese, these puncts shoule be rendered with East Asian text fonts by default, until the a paragraph or a small piece of text set another language and/or fonts.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.3.0.0.alpha0+ (x64)
Build ID: 3a5d78365dd172881c16c03e67f2d170ffc6d7d4
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-04-10_00:19:22
Locale: zh-CN (zh_CN); UI-Language: en-US
Calc: threaded

Also see: 

A Complaint of ODF’s Asian Language Support (includes a bug report for AOO)
https://yongweiwu.wordpress.com/2014/12/18/a-complaint-of-odfs-asian-language-support/

Interpunct - Wikipedia
https://en.wikipedia.org/wiki/Interpunct

Quotation mark - Wikipedia
https://en.wikipedia.org/wiki/Quotation_mark
Comment 1 Volga 2019-04-10 14:50:03 UTC
Created attachment 150661 [details]
Test ODT file
Comment 2 Hiunn-hué 2019-05-11 14:18:01 UTC
Similiar to this issue?
https://bugs.documentfoundation.org/show_bug.cgi?id=66791
Comment 3 Usama 2019-05-11 15:06:43 UTC
I think so, when I copy this text and close the quotation 
视觉效果 “test
it takes the font of the first punctuation mark from the text before but the last one from another

the same with Arabic
عربي "test”

and also similar to this #106306
https://bugs.documentfoundation.org/show_bug.cgi?id=106306
Comment 4 Volga 2019-05-13 07:11:32 UTC

*** This bug has been marked as a duplicate of bug 66791 ***