Bug 124682 - FILEOPEN DOCX Footer repeats in sections without footer
Summary: FILEOPEN DOCX Footer repeats in sections without footer
Status: RESOLVED DUPLICATE of bug 89297
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: DOCX-Header-Footer
  Show dependency treegraph
 
Reported: 2019-04-11 10:16 UTC by NISZ LibreOffice Team
Modified: 2019-04-13 15:02 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (55.47 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-04-11 10:18 UTC, NISZ LibreOffice Team
Details
Screenshot (187.89 KB, image/png)
2019-04-11 10:19 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2019-04-11 10:16:43 UTC
Description:
Footer in DOCX document created with Microsoft Word repeats when the document is opened in LibreOffice Writer 5.3.0.0.alpha0+.

Steps to Reproduce:
    1. Open the attached DOCX file in LibreOffice Writer 57fad5b21b4236ab73d90e34a21e60a0474e33f7.
    2. Open a copy in LibreOffice Writer 9d906f1acbcd6e982873fc02842e6f81aa625c34.
    3. Compare the original file opened in the two different builds of LibreOffice Writer.
    4. View the attached screenshot.
    5. Notice, that footer appears on the second and third pages, while in Word it’s only present on the first page.

Actual Results:
Footer repeats when the document is opened in LibreOffice Writer 5.3.0.0.alpha0+ 57fad5b21b4236ab73d90e34a21e60a0474e33f7.

Expected Results:
Footer should be only on the first page file when the document is opened in LibreOffice Writer 5.3.0.0.alpha0+ 9d906f1acbcd6e982873fc02842e6f81aa625c34.


Reproducible: Always


User Profile Reset: No



Additional Info:
LibreOffice details:
Version: 5.3.0.0.alpha0+
Build ID: 50bf96d31ab2eb546f6c71cc93c1fa5dd4bf3044
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
Locale: hu-HU (hu_HU)

Does not occur on:
Verzió: 5.2.0.4
Build az.: 066b007f5ebcc236395c7d282ba488bca6720265
CPU szálak: 4; Rendszer verziója: Windows 6.2; Felületmegjelenítés: GL; 
Területi beállítások: hu-HU (hu_HU)

Bibisect log:
# bad: [a374222bc87bd9e75ea2f1ca45d189932a1967f8] source sha:aa09fd58bd499a2a2c3a32c5f613892bad54076c
# good: [defb73f1c6e2a66dbd21ba89e684f57427e8bc4b] source sha:5b168b3fa568e48e795234dc5fa454bf24c9805e
git bisect start 'origin/master' 'oldest'
# bad: [0b4408f0568ad1da0797543c0ee2955c386267ee] source sha:8f7886c742cae5e012e52029c20925aa7b0fb6ea
git bisect bad 0b4408f0568ad1da0797543c0ee2955c386267ee
# bad: [16b554fa5f3a3d2723e78d894d644ac9303a7991] source sha:50a6f3d51f32e7176c3b2d036c60bb48d51d6a1a
git bisect bad 16b554fa5f3a3d2723e78d894d644ac9303a7991
# bad: [16b554fa5f3a3d2723e78d894d644ac9303a7991] source sha:50a6f3d51f32e7176c3b2d036c60bb48d51d6a1a
git bisect bad 16b554fa5f3a3d2723e78d894d644ac9303a7991
# bad: [16b554fa5f3a3d2723e78d894d644ac9303a7991] source sha:50a6f3d51f32e7176c3b2d036c60bb48d51d6a1a
git bisect bad 16b554fa5f3a3d2723e78d894d644ac9303a7991
# good: [e6174abf6e484f450bee6e52415805a2b8960ee0] source sha:011128aa9493a680c3e9da6d074f125a90ec455c
git bisect good e6174abf6e484f450bee6e52415805a2b8960ee0
# bad: [0b6d38bba485949b7fce1e73e4a4fadeb9bfa1f9] source sha:0a93639221a9de78eb548cf73a616f74c464d7ce
git bisect bad 0b6d38bba485949b7fce1e73e4a4fadeb9bfa1f9
# good: [db51c31399d7851ae9471db7e1530ba6af11e4be] source sha:2d67042dc2f0672d1aca4784e61eb2a5d0e91e08
git bisect good db51c31399d7851ae9471db7e1530ba6af11e4be
# good: [8df1b283710db48e714502913de178a0a6774531] source sha:ea6536a42b73c9205c9c69ddc5fecb9ed83c440e
git bisect good 8df1b283710db48e714502913de178a0a6774531
# bad: [11d47de815fd147cff0acdbef57f18dec99da3a5] source sha:42486dde49d9a9494c1f4889bbccde1f5aecd91e
git bisect bad 11d47de815fd147cff0acdbef57f18dec99da3a5
# good: [61be9123be3446b07f2b76a850a2dbeac1385969] source sha:6439d93cbe64bacba1bcb858dd7cbb6a33fca60b
git bisect good 61be9123be3446b07f2b76a850a2dbeac1385969
# bad: [efe6616d5006586067bb09d0f985f0ff32a5b087] source sha:541fcc978d69e6ba10e4005fd6e38658100bc112
git bisect bad efe6616d5006586067bb09d0f985f0ff32a5b087
# bad: [57fad5b21b4236ab73d90e34a21e60a0474e33f7] source sha:50bf96d31ab2eb546f6c71cc93c1fa5dd4bf3044
git bisect bad 57fad5b21b4236ab73d90e34a21e60a0474e33f7
# good: [26fd387974de02a5aff01dc5261d6159f39807e2] source sha:94809ea0d4101679794bb239313c4d73fab30419
git bisect good 26fd387974de02a5aff01dc5261d6159f39807e2
# good: [187fc71bacb4106e8ee3fbd60d3d3683c8c7fb35] source sha:24dcbccee7b1e35473187a77852afc8eee87ed2a
git bisect good 187fc71bacb4106e8ee3fbd60d3d3683c8c7fb35
# good: [9d906f1acbcd6e982873fc02842e6f81aa625c34] source sha:1294013bf5d373ded1d050370569acdc2b68c5f5
git bisect good 9d906f1acbcd6e982873fc02842e6f81aa625c34
# first bad commit: [57fad5b21b4236ab73d90e34a21e60a0474e33f7] source sha:50bf96d31ab2eb546f6c71cc93c1fa5dd4bf3044
Comment 1 NISZ LibreOffice Team 2019-04-11 10:18:30 UTC
Created attachment 150691 [details]
Example file
Comment 2 NISZ LibreOffice Team 2019-04-11 10:19:02 UTC
Created attachment 150692 [details]
Screenshot
Comment 3 NISZ LibreOffice Team 2019-04-11 10:25:32 UTC
Adding Cc: to Justin Luth
Comment 4 mulla.tasanim 2019-04-13 06:24:00 UTC
Thank you for reporting the bug.

I can confirm that the bug is present in

Version: 6.2.1.2 (x64)
Build ID: 7bcb35dc3024a62dea0caee87020152d1ee96e71
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: CL


Version: 6.3.0.0.alpha0+ (x64)
Build ID: 91cdf22b88a4f7bec243c8fb187627e766d3294c
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-03-08_00:38:10
Locale: en-US (en_US); UI-Language: en-US
Calc: CL
Comment 5 Justin L 2019-04-13 14:46:42 UTC
author	Justin Luth  2016-06-29 07:35:54 +0000
commit	50bf96d31ab2eb546f6c71cc93c1fa5dd4bf3044

bug 90697 docx - don't change continuous break into page break
As soon as you set PROP_PAGE_DESC_NAME, you are inserting that
style as a page break.  Setting a pagebreak via a continuous break
was first introduced in commit 50cb1667020494906afaacb68d4163d1eda527cf
but the unit test for that commit no longer uses this code.
I'm suggesting it be reverted.  It really messes up round-tripping
when continuous breaks are removed/replaced with hard page breaks.

There are a few odd cases where the very first section needs to set the
page break via the continuous break, so it hasn't been eliminated
completely.
Comment 6 Justin L 2019-04-13 15:02:42 UTC
LibreOffice cannot do anything like continuous breaks, so any document using them instead of section page breaks will have terrible compatibility.

Marking as duplicate since it deals with the same thing - import and export are irrelevant.

This document very clearly should have a section page-break instead of a section - continuous break at the bottom of the first page.

*** This bug has been marked as a duplicate of bug 89297 ***