Bug 124720 - CRASH: after pasting and undoing
Summary: CRASH: after pasting and undoing
Status: VERIFIED DUPLICATE of bug 117185
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha1+
Hardware: All All
: high major
Assignee: Michael Stahl (CIB)
URL:
Whiteboard:
Keywords: bibisected, bisected, regression, wantBacktrace
Depends on:
Blocks: Undo-Redo
  Show dependency treegraph
 
Reported: 2019-04-13 13:35 UTC by Xisco Faulí
Modified: 2019-07-29 14:34 UTC (History)
4 users (show)

See Also:
Crash report or crash signature: ["SwUndoDelete::UndoImpl(sw::UndoRedoContext &)"]


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2019-04-13 13:35:40 UTC
Steps to reproduce:
1. Open attachment 74331 [details] from bug 60413
2. Select all
3. Copy
4. Paste
5. Undo

Reproduced in

Version: 6.3.0.0.alpha0+
Build ID: 3b518953a8141b0d5043c2f3996a92956fdc3a47
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Xisco Faulí 2019-04-13 13:37:55 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=723728cd358693b8f4bc9d913541aa4479f2bd48

author	Michael Stahl <Michael.Stahl@cib.de>	2018-08-22 17:09:02 +0200
committer	Michael Stahl <Michael.Stahl@cib.de>	2018-09-19 10:18:29 +0200
commit	723728cd358693b8f4bc9d913541aa4479f2bd48 (patch)
tree	1ac75a662a46987301ea85d32957eb08f435ffd6
parent	41d8ca9686c7c184f586e99674b443c34bfd4f33 (diff)
sw_redlinehide_2: SwUndoDelete

Bisected with: bibisect-linux64-6.2

Adding Cc: to Michael Stahl
Comment 2 Xisco Faulí 2019-04-13 14:48:57 UTC
attachment 114429 [details] from bug 90309 is also affected
Comment 3 Oliver Brinzing 2019-04-13 15:54:36 UTC
reproducible with

Version: 6.2.3.1 (x64)
Build-ID: 9ba025bafb03b962c34687cf87806cc03a3a7436
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc:
Comment 4 Xisco Faulí 2019-04-14 12:26:25 UTC
attachment 119830 [details] from bug 95228 is also affected
Comment 5 Michael Stahl (CIB) 2019-07-22 11:20:32 UTC
fixed on master

*** This bug has been marked as a duplicate of bug 117185 ***
Comment 6 Xisco Faulí 2019-07-29 14:34:32 UTC
Verified in

Version: 6.4.0.0.alpha0+
Build ID: 0d36b32755ac662299e6a8165e9fa57311b74a2f
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Michael Stahl, thanks for fixing this issue!