Bug 124722 - CRASH: after pasting, if deleting more text than fits on a page
Summary: CRASH: after pasting, if deleting more text than fits on a page
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: target:6.3.0 target:6.2.4
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Paste
  Show dependency treegraph
 
Reported: 2019-04-13 14:35 UTC by Xisco Faulí
Modified: 2019-04-27 10:23 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2019-04-13 14:35:46 UTC
Steps to reproduce:
1. Open attachment 43860 [details] from 34779
2. Select all
3. Copy
4. Paste

-> Crash

Reproduced in

Version: 6.3.0.0.alpha0+
Build ID: 3b518953a8141b0d5043c2f3996a92956fdc3a47
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Xisco Faulí 2019-04-13 14:37:18 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=0acde7514e666fc04805fd36503bd174162336ca

author	Michael Stahl <Michael.Stahl@cib.de>	2019-01-21 12:30:20 +0100
committer	Michael Stahl <Michael.Stahl@cib.de>	2019-01-21 14:53:29 +0100
commit	0acde7514e666fc04805fd36503bd174162336ca (patch)
tree	6a0f1d2cd4963cff538127076621ee8c171637ea
parent	1b1999009962b9d79858139bd7573947f78e6669 (diff)
sw_redlinehide: fix assert caused by buggy lcl_ModifyOfst

Bisected with: bibisect-linux64-6.3

Adding Cc: to Michael Stahl
Comment 2 Oliver Brinzing 2019-04-13 16:07:06 UTC
reproducoble with:

Version: 6.3.0.0.alpha0+ (x64)
Build ID: d644a561eeb3e6ceb943819895a40c461effdbe6
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-US
Calc: threaded
Comment 3 Commit Notification 2019-04-16 12:34:56 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/2ea6f385d36966de8e30b9a537ac2875075ca9eb%5E%21

tdf#124722 sw_redlinehide: don't set negative SwTextFrame offsets

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Michael Stahl (CIB) 2019-04-16 12:36:35 UTC
fixed on master
Comment 5 Commit Notification 2019-04-16 22:55:01 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/1149d20ce9f8682b58f98d3fa3bf289fc5974087%5E%21

tdf#124722 sw_redlinehide: don't set negative SwTextFrame offsets

It will be available in 6.2.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Xisco Faulí 2019-04-17 09:33:59 UTC
Verified in

Version: 6.3.0.0.alpha0+
Build ID: a96167f88aa68651f055aa9096e63c9e48c8e4fa
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Michael Stahl, thanks for fixing this issue!!
Comment 7 Commit Notification 2019-04-27 10:21:13 UTC
Zdeněk Crhonek committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/af50621c2cc17414b52a5f4cbc2f65e1b685e252%5E%21

uitest for bug tdf#124722

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.