Bug 124725 - The LibreOffice Help Webpage- Can't search for anything after typing what I wanted to look for & pressing "Enter"
Summary: The LibreOffice Help Webpage- Can't search for anything after typing what I w...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
6.2.2.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.2.4
Keywords:
Depends on:
Blocks:
 
Reported: 2019-04-14 03:19 UTC by tokeithlaw2003
Modified: 2019-04-25 11:46 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot of the Help page issue (259.34 KB, image/png)
2019-04-14 03:23 UTC, tokeithlaw2003
Details
Screenshot (195.96 KB, image/png)
2019-04-23 09:21 UTC, tokeithlaw2003
Details
Screenshot (129.41 KB, image/png)
2019-04-23 09:22 UTC, tokeithlaw2003
Details
Screenshot (182.73 KB, image/png)
2019-04-23 09:22 UTC, tokeithlaw2003
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tokeithlaw2003 2019-04-14 03:19:37 UTC
Description:
It isn't the software issue.It's about the LibreOffice Help Webpage.Before I upgraded LibreOffice to version 6, I could search for something(e.g. creating form & questionnaire in LibreOffice Writer) that I need help on by typing this on LibreOffice Help Webpage.

After upgrading the software to version 6,I can no longer do that.

Actual Results:
N/A.

Expected Results:
N/A.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 tokeithlaw2003 2019-04-14 03:23:21 UTC
Created attachment 150738 [details]
Screenshot of the Help page issue
Comment 2 mulla.tasanim 2019-04-14 06:02:13 UTC
Thank you for reporting the bug.


LibreOffice Help Webpage is working fine in

Version: 6.2.1.2 (x64)
Build ID: 7bcb35dc3024a62dea0caee87020152d1ee96e71
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: CL


Version: 6.3.0.0.alpha0+ (x64)
Build ID: 91cdf22b88a4f7bec243c8fb187627e766d3294c
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-03-08_00:38:10
Locale: en-US (en_US); UI-Language: en-US
Calc: CL
Comment 3 Buovjaga 2019-04-19 15:51:25 UTC
I see you are using Edge. It seems to be working for me with the very latest version at least. Do you have problems with this: https://helponline.libreoffice.org/6.3/ ?
Comment 4 tokeithlaw2003 2019-04-23 09:20:43 UTC
(In reply to Buovjaga from comment #3)
> I see you are using Edge. It seems to be working for me with the very latest
> version at least. Do you have problems with this:
> https://helponline.libreoffice.org/6.3/ ?

I guess the problem isn't about the browser.I've tried to access https://helponline.libreoffice.org/6.3/ using both Google Chrome & Microsoft Edge & both are working fine(i.e. I can search for some of the topics/functions that I'm looking for).

Perhaps the problem is about the offline help file of Libre Office version 6.2.I access this offline help file by clicking "help" tab & then "LibreOffice Help"(See attachment "Screenshot1").

Then after typing,say PV function, in the search box & pressing "Enter" button on my keyboard,the webpage didn't return any search result(See attachment "Screenshot2").

However,when I use the link that you've provided in your former email(i.e. LibreOffice version 6.3 online help page), searching for the same PV function did returned search result(See attachment "Screenshot3").

Do you have any ideas how I can resolve this problem?Or does it mean I need to go to the online help page every time I want to look for help regarding a topic(& can't do it offline in the built-in help file)?

Thanks.

Kind Regards
Keith
Comment 5 tokeithlaw2003 2019-04-23 09:21:48 UTC
Created attachment 150937 [details]
Screenshot
Comment 6 tokeithlaw2003 2019-04-23 09:22:10 UTC
Created attachment 150938 [details]
Screenshot
Comment 7 tokeithlaw2003 2019-04-23 09:22:37 UTC
Created attachment 150939 [details]
Screenshot
Comment 8 Buovjaga 2019-04-23 10:45:33 UTC
Ok, it's a problem with the regular expression looking at the url.
Comment 9 Buovjaga 2019-04-23 10:54:29 UTC
Blah, this is already fixed for 6.3 by using window.location.pathname for getting the URL.
Comment 10 Commit Notification 2019-04-25 11:04:28 UTC
Ilmari Lauhakangas committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/help/+/455c31acf023c7c739629eb41eb957c5727dd62d%5E%21

tdf#124725 use window.location.pathname