Bug 124769 - FILEOPEN DOCX: Paragraph indent changes (comment 11)
Summary: FILEOPEN DOCX: Paragraph indent changes (comment 11)
Status: RESOLVED DUPLICATE of bug 108493
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.7.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: DOCX-Paragraph Paragraph-Indent
  Show dependency treegraph
 
Reported: 2019-04-16 12:27 UTC by Patrick Jaap
Modified: 2019-07-12 08:10 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
sample docx (16.91 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-04-16 12:27 UTC, Patrick Jaap
Details
MSO result (5.03 KB, application/pdf)
2019-04-16 12:27 UTC, Patrick Jaap
Details
LO Writer result (8.59 KB, application/pdf)
2019-04-16 12:28 UTC, Patrick Jaap
Details
Office result (15.69 KB, application/pdf)
2019-04-16 12:38 UTC, Patrick Jaap
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Jaap 2019-04-16 12:27:02 UTC
Description:
Writer breaks the line, MSO not.

Steps to Reproduce:
1. open the docx

Actual Results:
two lines

Expected Results:
one line


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Patrick Jaap 2019-04-16 12:27:31 UTC
Created attachment 150785 [details]
sample docx
Comment 2 Patrick Jaap 2019-04-16 12:27:53 UTC
Created attachment 150786 [details]
MSO result
Comment 3 Patrick Jaap 2019-04-16 12:28:11 UTC
Created attachment 150787 [details]
LO Writer result
Comment 4 Dieter 2019-04-16 12:33:30 UTC
I can't see a difference between MSO 2016 and LO 6.2.2.2

Could you please try to reproduce it with the latest version of LibreOffice from https://www.libreoffice.org/download/libreoffice-fresh/ ? I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the latest version. Change to RESOLVED WORKSFORME, if the problem went away.

Additional information: Attachment from comment 2 seems to be wrong
Comment 5 Oliver Sander 2019-04-16 12:37:24 UTC
Hi Patrick, the second attachment is incorrect.  You attached the wrong file.
Comment 6 Patrick Jaap 2019-04-16 12:38:59 UTC
Created attachment 150794 [details]
Office result
Comment 7 Patrick Jaap 2019-04-16 12:39:40 UTC
(In reply to Oliver Sander from comment #5)
> Hi Patrick, the second attachment is incorrect.  You attached the wrong file.

Sorry, fixed it
Comment 8 Patrick Jaap 2019-04-16 12:42:15 UTC
(In reply to Dieter Praas from comment #4)
> I can't see a difference between MSO 2016 and LO 6.2.2.2
> 
> Could you please try to reproduce it with the latest version of LibreOffice
> from https://www.libreoffice.org/download/libreoffice-fresh/ ? I have set
> the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if
> the bug is still present in the latest version. Change to RESOLVED
> WORKSFORME, if the problem went away.

Hi! I just tested it again with current master (still two lines). In Microsoft Office 2013 I see only one line.

> 
> Additional information: Attachment from comment 2 seems to be wrong
sorry, fixed it
Comment 9 Dieter 2019-04-16 13:31:52 UTC
(In reply to Patrick Jaap from comment #8)
> Hi! I just tested it again with current master (still two lines).

Only one line with

Version: 6.3.0.0.alpha0+ (x64)
Build ID: 421e6fc3cd2e6fe37afbef341e2d0ad7b8edde37
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-04-07_01:12:58
Locale: en-US (de_DE); UI-Language: en-US
Calc: threaded
Comment 10 Patrick Jaap 2019-04-16 13:35:08 UTC
(In reply to Dieter Praas from comment #9)

> 
> Only one line with
> 
> Version: 6.3.0.0.alpha0+ (x64)
> Build ID: 421e6fc3cd2e6fe37afbef341e2d0ad7b8edde37
> CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
> TinderBox: Win-x86_64@42, Branch:master, Time: 2019-04-07_01:12:58
> Locale: en-US (de_DE); UI-Language: en-US
> Calc: threaded

Hmm strange. Two lines with

Version: 6.0.7.3
Build-ID: 1:6.0.7-0ubuntu0.18.04.5
CPU-Threads: 8; BS: Linux 4.18; UI-Render: Standard; VCL: gtk3; 
Gebietsschema: de-DE (de_DE.UTF-8); Calc: group

and

Version: 6.3.0.0.alpha0+
Build ID: 6340daac7b99c65249363a4bb61c492de31ef5d6
CPU threads: 8; OS: Linux 4.18; UI render: default; VCL: gtk3; 
Locale: de-DE (de_DE.UTF-8); UI-Language: en-US
Calc: CL

Maybe a problem with the font or the operating system?
Comment 11 Dieter 2019-04-16 14:18:25 UTC
Let's compare

LO 6.3.0.0
margins: 2,5 cm left and 2,5 cm right
indent: 1,7 cm

MSO 2016
margins: 2,5 cm left and 2,5 cm right
indent: 1,3 cm

=> Indent changes




Additional information: When I open the file in MSO 2016 it is opended in "Geschützte Ansicht". In this view it has two lines. If I choose "Bearbeitung aktivieren" the text is in one line
Comment 12 Patrick Jaap 2019-04-16 14:36:03 UTC
> LO 6.3.0.0
> margins: 2,5 cm left and 2,5 cm right
> indent: 1,7 cm
> 
> MSO 2016
> margins: 2,5 cm left and 2,5 cm right
> indent: 1,3 cm
> 
> => Indent changes

That sounds promising. I can confirm that. If I change the indent in LO to 1,3cm I get one line and the other way around: If I change it in MSO 2013 to 1,7cm I get the line break.

Thanks for pointing that out!
Comment 13 Gabor Kelemen 2019-07-12 08:10:00 UTC
I think this is a duplicate.

What's also interesting is that the amount of the hanging indent (0.4 cm in this file) is added to the indent before, but only on screen and not on docx save: the original value is written to the file.

*** This bug has been marked as a duplicate of bug 108493 ***