Bug 124771 - XLSX: Wrong conditional formatting
Summary: XLSX: Wrong conditional formatting
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:xlsx
Depends on:
Blocks: XLSX-Conditional-Formatting
  Show dependency treegraph
 
Reported: 2019-04-16 12:35 UTC by Patrick Jaap
Modified: 2019-04-17 13:18 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
sample xlsx (10.00 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2019-04-16 12:36 UTC, Patrick Jaap
Details
LO Calc result (18.49 KB, application/pdf)
2019-04-16 12:36 UTC, Patrick Jaap
Details
Excel result (160.83 KB, application/pdf)
2019-04-16 12:37 UTC, Patrick Jaap
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Jaap 2019-04-16 12:35:46 UTC
Description:
In Office only cells above 1 are colored red, in LO Calc all cells are colored red.

Steps to Reproduce:
1. open the xlsx

Actual Results:
two red cells

Expected Results:
one red cell


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Patrick Jaap 2019-04-16 12:36:07 UTC
Created attachment 150791 [details]
sample xlsx
Comment 2 Patrick Jaap 2019-04-16 12:36:45 UTC
Created attachment 150792 [details]
LO Calc result
Comment 3 Patrick Jaap 2019-04-16 12:37:08 UTC
Created attachment 150793 [details]
Excel result
Comment 4 m.a.riosv 2019-04-16 17:52:02 UTC
The spreadsheet has Menu/Data/Calculate/Autocalculate disable, and conditional format in calc only works if Autocalculate it's enable (by design).

So enable it, and saving the file or doing a hard recalc Menu/Data/Calculate/Recalculate hard, fix the situation.
Comment 5 Oliver Sander 2019-04-17 07:17:43 UTC
Enabling AutoCalculate and saving does indeed solve the problem.

Simply doing Menu/Data/Calculate/Recalculate does not.  Is that a bug?
Comment 6 m.a.riosv 2019-04-17 07:27:54 UTC
(In reply to Oliver Sander from comment #5)
> Enabling AutoCalculate and saving does indeed solve the problem.
> 
> Simply doing Menu/Data/Calculate/Recalculate does not.  Is that a bug?

Not,
Comment 7 Oliver Sander 2019-04-17 08:03:01 UTC
Thanks for your quick answer, but it looks truncated.  Is it?  

Or if you just wanted to say 'no', why is it not a bug?  In Comment 4 you said

  "So enable it, and saving the file or ***doing a hard recalc Menu/Data/Calculate/Recalculate hard***, fix the situation."
Comment 8 m.a.riosv 2019-04-17 08:24:32 UTC
(In reply to Oliver Sander from comment #7)
> Thanks for your quick answer, but it looks truncated.  Is it?  
> 
> Or if you just wanted to say 'no', why is it not a bug?  In Comment 4 you
> said
> 
>   "So enable it, and saving the file or ***doing a hard recalc
> Menu/Data/Calculate/Recalculate hard***, fix the situation."

Not a bug.

As explained in comment#4 by design conditional format only works with Autocalculate enable.
Comment 9 Oliver Sander 2019-04-17 08:36:46 UTC
Sorry for being a nuisance.  Even if I enable AutoCalculate and then press Recalculate the problematic cell remains red.  I can only make it go white by saving.
Comment 10 m.a.riosv 2019-04-17 12:05:09 UTC
Menu/Data/Calculate/Recalculate hard
Comment 11 Oliver Sander 2019-04-17 13:18:23 UTC
Ah, turns out my LO is too old to even have "recalculate hard".  With a new version the "calculate" menu does have the "hard" entry, and everything works as you say.  Thanks for your help.