Download it now!
Bug 124844 - After adding a caption to an image the text cursor disappears, making it unable to input text
Summary: After adding a caption to an image the text cursor disappears, making it unab...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.2.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: KDE Text-Cursor
  Show dependency treegraph
 
Reported: 2019-04-19 10:54 UTC by JORGETECH
Modified: 2019-10-20 18:55 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description JORGETECH 2019-04-19 10:54:47 UTC
Description:
When I add a caption to an image the text cursor disappears in the UI and I cannot write anymore nor modify existing text.

I haven't seen this bug in older version.

Steps to Reproduce:
1. Open or create a LibreOffice Writer document.
2. Input some text as you would normally do.
3. Add an image to the document.
4. Add a caption to the added image.

Actual Results:
After adding the caption to the image the text cursor suddenly disappears and I am not able to write or modify text on the document (however, I am able to select text). Closing and opening LibreOffice fixes the problem.

Expected Results:
The text cursor should not disappear and you should be able to write or modify existing text.


Reproducible: Sometimes


User Profile Reset: No



Additional Info:
The VCL I am using is: kde5
Comment 1 Timur 2019-04-19 14:57:41 UTC
No repro Windows and Linux Mint. 
I see that cursor is not visible, but I can just click after the text and type. 
Do you mean you cannot click in the text to get cursor and type?
Comment 2 Roman Kuznetsov 2019-04-20 10:05:57 UTC
please add info from dialog Help->About LibreOffice
Comment 3 Roman Kuznetsov 2019-04-20 10:07:23 UTC
don't repro in

Version: 6.3.0.0.alpha0+
Build ID: 9079da7f62febaf4cef0b77320c31b4e8bb6b5a5
CPU threads: 4; OS: Linux 5.0; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-04-06_02:52:37
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded
Comment 4 JORGETECH 2019-04-20 11:01:42 UTC
Timur, I tried doing the same as you but the cursor only returns after right-clicking. If I click in the text I don't get the cursor back and I cannot type anymore unless I open the right-click menu.

More info about my setup as Roman requested:

Version: 6.2.2.2
Build ID: 1:6.2.2-0ubuntu2
CPU Threads: 4
OS: Linux 5.0
UI render: default
VCL: kde5
Locale: es-ES (es_ES.UTF-8)
UI-Language: en-US (normally es-ES)
Calc:threaded

I am using Kubuntu 19.04 and I can reproduce this on the LibreOffice version from Ubuntu and the one from LibreOffice Fresh PPA.
Comment 5 JORGETECH 2019-04-20 11:17:50 UTC
I also observed similar issues when interacting with tables (when dividing or joining in tables for example).
Comment 6 Timur 2019-04-22 07:09:52 UTC
Could you please create and attach a screencast showing the steps?
There are various free screencast software available for use, including Camstudio (Windows), Jing (Mac), Simple Screen Recorder (Linux) or screencast-o-matic.com (Web).
Comment 7 JORGETECH 2019-04-22 19:50:37 UTC
I'll do it and send it when ready
Comment 8 Michael Weghorn 2019-04-23 16:20:13 UTC
Also, do you have any input methods (like ibus, fcitx) enabled?
Comment 9 Jan-Marek Glogowski 2019-06-09 16:22:04 UTC
Does it happen with other VCLs, like SAL_USE_VCLPLUGIN=gtk3? And please always verify with "About LibreOffice", as LO does automatic fallback for missing VCLs.
Comment 10 JORGETECH 2019-10-20 18:13:59 UTC
I tried to reproduce the bug in the newest version of LibreOffice (6.3) and I think it was fixed. I will proceed to close the bug.