Download it now!
Bug 124851 - Wrong toolbar colors on Windows classic theme
Summary: Wrong toolbar colors on Windows classic theme
Status: RESOLVED DUPLICATE of bug 108145
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.2.2.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Notebookbar-Groupedbar Notebookbar-Tabbed
  Show dependency treegraph
 
Reported: 2019-04-19 23:05 UTC by NotMyName-42
Modified: 2019-05-15 02:58 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
wrong colors (60.41 KB, image/jpeg)
2019-04-19 23:06 UTC, NotMyName-42
Details
screenshot of release notes on top, actual application on win7 with classic theme below. (96.72 KB, image/jpeg)
2019-04-19 23:06 UTC, NotMyName-42
Details
Looks on dark theme of Linux Mint - low contrast (39.43 KB, image/jpeg)
2019-05-13 09:39 UTC, NotMyName-42
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NotMyName-42 2019-04-19 23:05:49 UTC
Description:
On Windows 7 using a classic (or individual) theme:
Tabbed UI and Groupedbar Compact UI use a wrong background color for buttons / icons that clashes with the actual window color.

Steps to Reproduce:
1. choose classic theme on win7
2. use libreoffice Tabbed UI or Groupedbar Compact UI 
3. be overwhelmed by ugly color clash

Actual Results:
UI is too ugly to use

Expected Results:
Use the background color set in Windows.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.2.2.2 (x64)
Build-ID: 2b840030fec2aae0fd2658d8d4f9548af4e3518d
CPU-Threads: 4; BS: Windows 6.1; UI-Render: Standard; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: threaded
Comment 1 NotMyName-42 2019-04-19 23:06:18 UTC
Created attachment 150889 [details]
wrong colors
Comment 2 NotMyName-42 2019-04-19 23:06:48 UTC
Created attachment 150890 [details]
screenshot of release notes on top,
actual application on win7 with classic theme below.
Comment 3 NotMyName-42 2019-05-13 09:39:14 UTC
Created attachment 151349 [details]
Looks on dark theme of Linux Mint - low contrast

(I don't know if this dark-theme issue is kind of the same or a different one)

Some dark icons are not visible on a dark background.

Icons like 'bold' and 'italic' are hard to identify,
others like 'format as per cent', 'format as decimal' and 'border style' (I do not know the correct english titles) can not perceived at all.
Comment 4 NotMyName-42 2019-05-13 09:43:55 UTC
Comment on attachment 151349 [details]
Looks on dark theme of Linux Mint - low contrast

correction: dark theme issue is bug 122514 where I added the last screenshot, too.
Comment 5 Heiko Tietze 2019-05-14 09:29:45 UTC
Thanks for reporting. Let's discuss the issue on bug 108145.

*** This bug has been marked as a duplicate of bug 108145 ***