Download it now!
Bug 124888 - Writer – Aspect Ratio Incorrect When Making Image Fit Paragraph Width
Summary: Writer – Aspect Ratio Incorrect When Making Image Fit Paragraph Width
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.5.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Paragraph-Dialog
  Show dependency treegraph
 
Reported: 2019-04-22 17:27 UTC by librelibre
Modified: 2019-12-21 03:33 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot 1 (202.30 KB, image/png)
2019-04-22 17:28 UTC, librelibre
Details
Screenshot 2 (109.65 KB, image/png)
2019-04-22 17:29 UTC, librelibre
Details
Screenshot 3 (98.83 KB, image/png)
2019-04-22 17:29 UTC, librelibre
Details
Screenshot 4 (112.41 KB, image/png)
2019-04-22 17:30 UTC, librelibre
Details
Screenshot 5 (131.60 KB, image/png)
2019-04-22 17:30 UTC, librelibre
Details
Screenshot 6 (111.80 KB, image/png)
2019-04-22 17:30 UTC, librelibre
Details
Screenshot 7 (130.64 KB, image/png)
2019-04-22 17:31 UTC, librelibre
Details
Screenshot 8 (116.92 KB, image/png)
2019-04-22 17:31 UTC, librelibre
Details

Note You need to log in before you can comment on or make changes to this bug.
Description librelibre 2019-04-22 17:27:12 UTC
Description:
When making an image fit the paragraph width, LibreOffice Writer incorrectly calculates the image dimensions, resulting in an incorrect image aspect ratio.

Steps to Reproduce:
I have attached screenshots of the steps required to reproduce the issue.

Actual Results:
LibreOffice Writer incorrectly calculates the image dimensions

Expected Results:
LibreOffice Writer should correctly calculate the image dimensions


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.1.5.2 (x64)
Build ID: 90f8dcf33c87b3705e78202e3df5142b201bd805
CPU threads: 4; OS: Windows 10.0 (17763.437); UI render: GL; 
Locale: en-GB (en_GB); Calc: group threaded
Comment 1 librelibre 2019-04-22 17:28:36 UTC
Created attachment 150919 [details]
Screenshot 1
Comment 2 librelibre 2019-04-22 17:29:15 UTC
Created attachment 150920 [details]
Screenshot 2
Comment 3 librelibre 2019-04-22 17:29:36 UTC
Created attachment 150921 [details]
Screenshot 3
Comment 4 librelibre 2019-04-22 17:30:05 UTC
Created attachment 150922 [details]
Screenshot 4
Comment 5 librelibre 2019-04-22 17:30:27 UTC
Created attachment 150923 [details]
Screenshot 5
Comment 6 librelibre 2019-04-22 17:30:46 UTC
Created attachment 150924 [details]
Screenshot 6
Comment 7 librelibre 2019-04-22 17:31:09 UTC
Created attachment 150925 [details]
Screenshot 7
Comment 8 librelibre 2019-04-22 17:31:33 UTC
Created attachment 150926 [details]
Screenshot 8
Comment 9 Dieter 2019-05-22 18:45:56 UTC
I confirm the behaviour with

Version: 6.3.0.0.alpha1+ (x64)
Build ID: e92dcfdc7bd7b237e0bee26ff226a102d9e8e766
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-05-14_00:00:57
Locale: en-US (de_DE); UI-Language: en-US
Calc: threaded

I assume the reason for this behaviour is, that LO doesn't offer percentages with decimal point.

=> Adding design team for input
Comment 10 Heiko Tietze 2019-05-23 08:21:19 UTC
What (numbers) do you expect at step 3 and 4 (width relative to paragraph)? And what's the problem with 6 to 8 (guess you click on Original Size and it should reset to 16.26 x 9.16 / 100% - but you also checked the aspect ratio).
Comment 11 QA Administrators 2019-11-20 03:51:45 UTC Comment hidden (obsolete)
Comment 12 QA Administrators 2019-12-21 03:33:43 UTC
Dear librelibre,

Please read this message in its entirety before proceeding.

Your bug report is being closed as INSUFFICIENTDATA due to inactivity and
a lack of information which is needed in order to accurately
reproduce and confirm the problem. We encourage you to retest
your bug against the latest release. If the issue is still
present in the latest stable release, we need the following
information (please ignore any that you've already provided):

a) Provide details of your system including your operating
   system and the latest version of LibreOffice that you have
   confirmed the bug to be present

b) Provide easy to reproduce steps – the simpler the better

c) Provide any test case(s) which will help us confirm the problem

d) Provide screenshots of the problem if you think it might help

e) Read all comments and provide any requested information

Once all of this is done, please set the bug back to UNCONFIRMED
and we will attempt to reproduce the issue. Please do not:

a) respond via email 

b) update the version field in the bug or any of the other details
   on the top section of our bug tracker

Warm Regards,
QA Team

MassPing-NeedInfo-FollowUp