Bug 124932 - UI: GTK3: in dialog Customize, the list Shortcut Keys doesn't get the focus with TAB, no other option to enter any widget
Summary: UI: GTK3: in dialog Customize, the list Shortcut Keys doesn't get the focus w...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.3.0 target:6.2.4
Keywords: bibisectRequest, regression
Depends on:
Blocks:
 
Reported: 2019-04-24 13:06 UTC by Cor Nouws
Modified: 2019-04-27 09:32 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cor Nouws 2019-04-24 13:06:02 UTC
in version Version: 6.3.0.0.alpha0+
Build ID: 89b1a00e08d8938714dd493fa27f08ba8d9b618d
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-04-21_15:52:39
Locale: nl-NL (nl_NL.UTF-8); UI-Language: en-US
Calc: threaded

Tools > Customize
Ctrl+Page down to Keyboard
TAB
   > nothing happens (as far as I can notice)
Comment 1 m.a.riosv 2019-04-24 21:29:43 UTC
Version: 6.3.0.0.alpha0+ (x64)
Build ID: 3083fe569f96bf0289da1e9d0ef7da15ab22e2f6
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-04-16_03:05:57
Locale: es-ES (es_ES); UI-Language: en-US
Calc: CL

Hi Cor, maybe I don't understand right, but after going to [Keyboard] with [Ctrl+Pgdw], [tab] cycles through the different parts of the window.
Comment 2 V Stuart Foote 2019-04-25 12:58:41 UTC
Not an issue on Windows builds, <Ctrl>+<Tab> moves between dialog Tabs, and <Tab> or <Shift>+<Tab> navigates to all elements of the Keyboard panel.

On Windows 10 Home 64-bit en-US (1809) with
Version: 6.3.0.0.alpha0+
Build ID: 951282a27a9dd4c64fc206fcbdd805b4cb602816
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 3 Cor Nouws 2019-04-25 13:21:22 UTC
(In reply to m.a.riosv from comment #1)
> Version: 6.3.0.0.alpha0+ (x64)
> Build ID: 3083fe569f96bf0289da1e9d0ef7da15ab22e2f6
> CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
> TinderBox: Win-x86_64@42, Branch:master, Time: 2019-04-16_03:05:57
> Locale: es-ES (es_ES); UI-Language: en-US
> Calc: CL
> 
> Hi Cor, maybe I don't understand right, but after going to [Keyboard] with
> [Ctrl+Pgdw], [tab] cycles through the different parts of the window.
Your understanding is fine Miguel :)
The problem is with GTK3 on Linux.
Comment 4 Caolán McNamara 2019-04-25 14:33:52 UTC
https://gerrit.libreoffice.org/#/c/71283/
Comment 5 Commit Notification 2019-04-25 14:44:53 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/254c344c4bee0516f8dcc1b31bd3c551a6a332c1%5E%21

Resolves: tdf#124932 fix Shortcut Keys etc tab traversal

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2019-04-27 09:32:52 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/f68925bf241092ae6701d72efdb298e5b86701b2%5E%21

Resolves: tdf#124932 fix Shortcut Keys etc tab traversal

It will be available in 6.2.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.