Bug Hunting Session
Bug 124957 - SLIDESHOW Impress presenter console regression: no slide shown on 2nd screen
Summary: SLIDESHOW Impress presenter console regression: no slide shown on 2nd screen
Status: RESOLVED DUPLICATE of bug 119719
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.2.3.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: KDE Presenter-Console
  Show dependency treegraph
 
Reported: 2019-04-25 13:39 UTC by Horst Schirmeier
Modified: 2019-04-25 14:57 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Horst Schirmeier 2019-04-25 13:39:25 UTC
Description:
In LO 6.2.3.2's Impress, starting the slide show with a second screen attached shows the presenter console on screen #1, but doesn't display anything on screen #2 (unchanged, desktop background still visible).  With LO 6.1.5.2 this works as expected (slide shown on screen #2).  Also reproducible with soffice --safe-mode.

Steps to Reproduce:
Environment: Ubuntu 18.04.2 LTS (amd64), KDE 5 with Plasma 5.12.7 (as shipped with Ubuntu), LO 6.2.3.2 "Linux x86_64 (deb)" from libreoffice.org, primary screen 2560x1440, secondary screen 1920x1200 extending the desktop rightwards (reproducible with other screens / resolutions).

1. Attach secondary screen, configure X.org to extend the desktop to the right (e.g. using xrandr, arandr, ...).
2. Run soffice 6.2.3.2.
3. On start screen: Create: Impress Presentation.  Pick arbitrary template.  Open.
4. Start presentation with F5.

Actual Results:
Primary screen shows presenter console (current slide, next slide, notes).  Secondary screen doesn't show current slide but continues displaying desktop background.

Expected Results:
Presenter console on primary screen, current slide on secondary screen.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 6.2.3.2
Build ID: aecc05fe267cc68dde00352a451aa867b3b546ac
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: kde5; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Horst Schirmeier 2019-04-25 14:06:56 UTC
Side note: Disabling "hardware acceleration" doesn't change the observations described.
Comment 2 Michael Weghorn 2019-04-25 14:57:56 UTC
Thank you for your bug report.

This seems to be the issue already described in bug 119719, so I'm marking it as a duplicate. The underlying problem has been fixed in Qt 5.10, so outside of LibreOffice itself. Ubuntu 18.04 only has Qt version 5.9.5.
Should your problem still be reproducible with a newer Qt version, please reopen this bug report.

*** This bug has been marked as a duplicate of bug 119719 ***