Bug 124967 - Regression: LibO says "unknown image format" trying to import tiff
Summary: Regression: LibO says "unknown image format" trying to import tiff
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
6.1.5.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Images-TIFF
  Show dependency treegraph
 
Reported: 2019-04-25 22:15 UTC by sergio.callegari
Modified: 2019-06-28 19:04 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Test case (124.81 KB, image/tiff)
2019-04-25 22:21 UTC, sergio.callegari
Details
Test case in pdf (7.00 KB, application/pdf)
2019-04-25 22:21 UTC, sergio.callegari
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sergio.callegari 2019-04-25 22:15:24 UTC
Description:
Title says all...

Steps to Reproduce:
See description

Actual Results:
See description

Expected Results:
See description


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: DrawingDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes
Comment 1 sergio.callegari 2019-04-25 22:20:19 UTC
Issue occurs with monochrome tiff file using Group4 compression.

Note that if the image is encapsulated in a pdf file, for instance using tiff2pdf, so that the pdf file contains an image with group 4 compression, LibO still cannot insert it properly (in this latter case, it inserts a blank rectangle).

Issue is also present in LibO 6.2.

This is a regression since LibO used to be able to insert Group4 tiff images, even if there were some glitches.
Comment 2 sergio.callegari 2019-04-25 22:21:08 UTC
Created attachment 151016 [details]
Test case
Comment 3 sergio.callegari 2019-04-25 22:21:35 UTC
Created attachment 151017 [details]
Test case in pdf
Comment 4 sergio.callegari 2019-04-25 22:29:41 UTC
OK, sorry for the noise... Looks like the tiff files were generated with some issue by the gimp. Other tools could manage them properly, but the files were much larger than they should have. Copying them with tiffcp "fixed" their size and the ability of LibO to deal with them. Issue with the pdf remains, though.