Bug 124968 - UI Performance Sllooowwww on 27" Retina iMac 2019 Model
Summary: UI Performance Sllooowwww on 27" Retina iMac 2019 Model
Status: RESOLVED DUPLICATE of bug 113104
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.2.3.2 release
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: HiDPI Scrolling-PageUpDown
  Show dependency treegraph
 
Reported: 2019-04-26 00:55 UTC by Damien
Modified: 2019-04-29 07:07 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Damien 2019-04-26 00:55:35 UTC
Description:
Using either Text Doc, Spreadsheet or Presentation, normal operation is very slow to the point of being unusable. Simply scrolling the window on a new document in any app is very laggy. I checked the CPU usage, and it spikes to 50% very quickly. Was trying to create a slide presentation of 20 slides and some small images (appts 8Mb in total) and the CPU was sitting around 100%. It seems to be a core UI issue across all Apps I have used.

I have just bought a new 2019 27" iMac, 32GB, 2TB SSD. Clean install with Mojave. Clean install of LibreOffice 6.2.3.2. Am running it side by side with my old 27in iMac, which does not show the problem. Seems to be a Retina issue?

Note: I can't select checkbox "Use Hardware Acceleration" it is greyed out and unchecked.

Steps to Reproduce:

1.Open any doc, eg a spreadsheet
2.Fill in a column worth of numbers, anything really.
3.Scroll up and down or left and right, very laggy.
4.Also watch CPU usage while doing this. 


Actual Results:
UI responsiveness is very slow.

Expected Results:
UI responsiveness not be very slow.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Comment 1 Alex Thurgood 2019-04-29 07:07:04 UTC

*** This bug has been marked as a duplicate of bug 113104 ***