Bug Hunting Session
Bug 124985 - Libreoffice cannot write to a network drive after upgrading from Ubuntu 18.10 to 19.04
Summary: Libreoffice cannot write to a network drive after upgrading from Ubuntu 18.10...
Status: RESOLVED DUPLICATE of bug 123472
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.2.2.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Network
  Show dependency treegraph
 
Reported: 2019-04-26 15:52 UTC by Jaroslaw Pioro
Modified: 2019-04-29 08:24 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jaroslaw Pioro 2019-04-26 15:52:34 UTC
Description:
After upgrading from Ubuntu 18.10 to 19.04 Libreoffice lost its ability to write to network drives. In my case it's a DAVS system, which I connect to using Nautilus. I access the file on the drive with Nautilus, open a file by double-clicking it, it opes without problems, I can change it and save it, but I cannot export the document as PDF or "Save As" another document at the same location. I get one popup window saying: "Error saving the document <document name>: Nonexistent file" and after closing it another one opens with "Error saving the document <document name>: General error. General input/output error".

The problem seems to emerge from time to time, as this example shows:
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1069757

Steps to Reproduce:
1. Map a network drive through Nautilus
2. Access a LibreOffice document on this drive, open it by double-clicking it
3. Try to export the document as PDF to the same location or try to save it under another name without changing the location of the file

Actual Results:
one popup window saying: "Error saving the document <document name>: Nonexistent file" apperars and after closing it another one opens with "Error saving the document <document name>: General error. General input/output error".

Expected Results:
The software should export a file or write it down under a new name.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.2.2.2
Build ID: 1:6.2.2-0ubuntu2
CPU threads: 8; OS: Linux 5.0; UI render: default; VCL: gtk3; 
Locale: pl-PL (pl_PL.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Stephan Bergmann 2019-04-29 06:48:54 UTC
Is that with the LibreOffice provided by Ubuntu?  If yes, please report the issue in Ubuntu's bug tracking system (and leave a link to that report here, fore reference).
Comment 2 Jaroslaw Pioro 2019-04-29 06:56:19 UTC
(In reply to Stephan Bergmann from comment #1)
> Is that with the LibreOffice provided by Ubuntu?  If yes, please report the
> issue in Ubuntu's bug tracking system (and leave a link to that report here,
> fore reference).

I have noticed the problem  with the Ubuntu package first and I have reported it through Ubuntu - the link is provided in the "See also" section of this ticket, but I post it here anyway:

https://launchpad.net/bugs/1826468

They asked me to report it here, so I did it. I have also uninstalled the Ubuntu package and installed the LibreOffice_6.2.3_Linux_x86-64_deb.tar.gz package, which is the latest stable version available on the LibreOffice official pages. The same problem occured, so it's not only the problem with the Ubuntu version.

I have also created a new system profile and confirmed that the problem still persists with the new account.
Comment 3 Stephan Bergmann 2019-04-29 08:24:05 UTC

*** This bug has been marked as a duplicate of bug 123472 ***