Bug Hunting Session
Bug 125018 - latest alpha version does not start up at all
Summary: latest alpha version does not start up at all
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
: 124592 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-04-29 08:04 UTC by Elmar
Modified: 2019-05-08 21:56 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Elmar 2019-04-29 08:04:15 UTC
Description:
master~2019-04-26_14.20.06_LibreOfficeDev_6.3.0.0.alpha0_Linux_x86-64_deb.tar.gz

Steps to Reproduce:
1. downloaded 26 and 28Apr masters
2. install
3. try, nothing happens

Actual Results:
nothing happens

Expected Results:
should open calc sheet


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: en-ZA
Module: SpreadsheetDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes
Comment 1 Xisco Faulí 2019-04-29 10:57:34 UTC
Does it work if you launch it line SAL_USE_VCLPLUGIN=gen  instdir/program/scalc ?
Comment 2 Elmar 2019-04-29 15:05:46 UTC
It is not just calc. No LO starts

I notice that soffice does not appear in the list of processes.

I get this when trying to start in terminal:
libreofficedev6.3 --calc %U
/opt/libreofficedev6.3/program/soffice.bin: error while loading shared libraries: libmergedlo.so: cannot open shared object file: No such file or directory

██ 17:04:02 $ SAL_USE_VCLPLUGIN=gen instdir/program/scalc
bash: instdir/program/scalc: No such file or directory
Comment 3 NISZ LibreOffice Team 2019-04-29 15:08:42 UTC
I tried to install LO master on Ubuntu Linux 14.04.
I chose versions from: https://dev-builds.libreoffice.org/daily/master/Linux-rpm_deb-x86_64@86-TDF/

With 2019-04-26_14.20.06 and 2019-04-28_10.00.14 versions I got this bug:
/opt/libreofficedev6.3/program/soffice.bin: error while loading shared libraries: libmergedlo.so: cannot open shared object file: No such file or directory

The 2019-04-20_20.05.57 and 2019-04-25_17.33.40 versions I could install.
Comment 4 MM 2019-04-29 23:00:23 UTC
Confirmed with mint 19.1 with https://dev-builds.libreoffice.org/daily/master/Linux-rpm_deb-x86_64@86-TDF/2019-04-26_14.20.06/master~2019-04-26_14.20.06_LibreOfficeDev_6.3.0.0.alpha0_Linux_x86-64_deb.tar.gz

Last version that worked was Version: 6.3.0.0.alpha0+
Build ID: 5e4c1e6ba425ce0b75864e4584a846957b032e61
CPU threads: 2; OS: Linux 4.15; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-04-25_17:33:40
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

Reset profile, yes.
Just unpacked the file, open terminal and use 'sudo dpkg -i *.deb'.
Then try to run LO, but LO quits directly after starting.
Comment 5 Xisco Faulí 2019-04-30 14:42:41 UTC
<cloph> yeah, please either use rpm package (can extract it with "for i in *.rpm; do rpm2cpio $i |cpio -idmv; done") or use the April 25 upload - currently trying to figure out why the debian core package only contains some help files and not the program libraries...
Comment 6 BogdanB 2019-05-03 12:43:15 UTC
Works ok now with installation from a .deb file

Version: 6.3.0.0.alpha0+
Build ID: 96ab20756316b25b7f2343a15596bc5114ea5a68
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-05-02_14:29:16
Locale: ro-RO (ro_RO.UTF-8); UI-Language: en-US
Calc: threaded
Comment 7 MM 2019-05-05 14:37:51 UTC
Yep, it works for me with Version: 6.3.0.0.alpha0+
Build ID: 98630a0bd49bd80652145a21e4e0d0ded792b36b
CPU threads: 2; OS: Linux 4.15; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-05-04_04:44:35
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 8 Xisco Faulí 2019-05-08 21:56:50 UTC
*** Bug 124592 has been marked as a duplicate of this bug. ***