Download it now!
Bug 125055 - XLSX export: a pivot table based on column having times with 1 s difference produces errors and is dropped when imported to Excel
Summary: XLSX export: a pivot table based on column having times with 1 s difference p...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Mike Kaganski
URL:
Whiteboard: target:6.3.0
Keywords: dataLoss, filter:xlsx
Depends on:
Blocks: XLSX-Corrupted Pivot-Table-XLSX
  Show dependency treegraph
 
Reported: 2019-05-01 04:21 UTC by Mike Kaganski
Modified: 2019-05-01 11:17 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
A pivot table based on two close datetimes (1 s difference) (11.91 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2019-05-01 04:21 UTC, Mike Kaganski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Kaganski 2019-05-01 04:21:55 UTC
Created attachment 151103 [details]
A pivot table based on two close datetimes (1 s difference)

Opening the attached spreadsheet, and re-saving as XLSX, then opening in Excel, produces warning about "found a problem with some content", then "Removed Feature: PivotTable report from /xl/pivotTables/pivotTable1.xml part (PivotTable view); Removed Records: Workbook properties from /xl/workbook.xml part (Workbook)". The pivot table is dropped (replaces with static content).

Since commit https://git.libreoffice.org/core/+/baed960b8ce55370a040d0c0f49bd3fdc16bdf84.

Not a regression: the said commit introduced saving datetime fields to pivot tables; previous to that, such fields weren't stored properly at all (implementation defect).
Comment 1 Mike Kaganski 2019-05-01 04:29:23 UTC
https://gerrit.libreoffice.org/71610
Comment 2 Commit Notification 2019-05-01 07:41:05 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/f8472069d451ec001e602bbc5329ad030fae1219%5E%21

tdf#125055: properly round fractions of seconds

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.