Download it now!
Bug 125057 - [FORMATTING] Conditional formatting KO while copying sheet
Summary: [FORMATTING] Conditional formatting KO while copying sheet
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.4.7.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks: Conditional-Formatting
  Show dependency treegraph
 
Reported: 2019-05-01 05:11 UTC by Florent Mathis
Modified: 2020-06-10 10:26 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Broken file (14.00 KB, application/vnd.oasis.opendocument.spreadsheet)
2019-05-01 05:13 UTC, Florent Mathis
Details
Workaround file (13.98 KB, application/vnd.oasis.opendocument.spreadsheet)
2019-05-01 05:15 UTC, Florent Mathis
Details
Original file (13.74 KB, application/vnd.oasis.opendocument.spreadsheet)
2019-05-01 05:16 UTC, Florent Mathis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Florent Mathis 2019-05-01 05:11:48 UTC
Description:
When I copy a sheet which contains conditional formatting, it seems to be working fine but the conditional formatting is broken on the new sheet. (see attachment)
I have found a workaround while browsing issues regarding conditional formatting by copying using the "paste special" directly on the cells after copying the sheet. However, this workaround may be time-consuming if, like in my case, one has to perform this operation multiple times.
Additionally, there is also a strange orange color which is automatically added on the nonworking cells.

Steps to Reproduce:
1. create a worksheet
2. apply a conditional formating (in my case, it was a custom style with a different background, conditionned on a LOV defined in another sheet)
3. copy the worksheet

Actual Results:
Conditional formatting broken in the new sheet.

Expected Results:
Copy the format with the sheet copy.


Reproducible: Always


User Profile Reset: No



Additional Info:
I also use a cell range for the broken cells. Both the definition of the cell range, and the conditional formatting are based on a configuration sheet _Status_LOV.
Comment 1 Florent Mathis 2019-05-01 05:13:57 UTC
Created attachment 151104 [details]
Broken file
Comment 2 Florent Mathis 2019-05-01 05:14:28 UTC
Comment on attachment 151104 [details]
Broken file

The broken file after having copied the tab "Sc_base" to "Sc_base_2"
Comment 3 Florent Mathis 2019-05-01 05:15:26 UTC
Created attachment 151105 [details]
Workaround file

File after workaround with "paste special"
Comment 4 Florent Mathis 2019-05-01 05:16:17 UTC
Created attachment 151106 [details]
Original file

Original file, before the tab copy
Comment 5 Roman Kuznetsov 2019-05-01 10:21:34 UTC
Florent, how do you copy a sheet? Say about it more detail
Comment 6 Florent Mathis 2019-05-01 14:04:32 UTC
@Roman, I right click on the origin sheet tab, select "move or copy sheet" and select the "copy" radio button.
Comment 7 QA Administrators 2019-05-08 21:51:10 UTC Comment hidden (obsolete)
Comment 8 Xisco Faulí 2019-05-09 08:53:12 UTC Comment hidden (obsolete)
Comment 9 Florent Mathis 2019-05-12 09:02:48 UTC
(In reply to Xisco Faulí from comment #8)
> Thank you for reporting the bug. To be certain the reported issue is not
> related to corruption in the user profile, could you please reset your
> Libreoffice profile ( https://wiki.documentfoundation.org/UserProfile ) and
> re-test?
> 
> I have set the bug's status to 'NEEDINFO'. Please change it back to
> 'UNCONFIRMED' if the issue is still present

I've restarted in safe mode and the problem still occurs. Just to be sure, I also have renamed my user profile folder in appdata and it also occurs.
Comment 10 Roman Kuznetsov 2019-05-12 10:19:35 UTC
Repro. 
Link to target "equal to" is wrong for all condition. 
It was (for Condition 1) $_Status_LOV.$A$3 and it became for copied sheet - $Sc_base.$A$3. 
There is an absolutely addressing but it doesn't work when we copy sheet with CF now


Version: 6.3.0.0.alpha0+ (x64)
Build ID: 4cd4063f9cf531d1e948f27fcfd2eaed3d4a1a2d
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-05-08_23:08:36
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded
Comment 11 Roman Kuznetsov 2019-05-12 11:26:22 UTC
don't repro in 4.2.8 but repro in 4.4.7 ->regression
Comment 12 Buovjaga 2020-06-06 14:21:21 UTC
I can't reproduce. Florent, Roman: can you please re-test?

Arch Linux 64-bit
Version: 7.1.0.0.alpha0+
Build ID: 2bccbd2ba6c90d5e02285629c2b079c35260c08b
CPU threads: 8; OS: Linux 5.6; UI render: default; VCL: kf5
Locale: fi-FI (fi_FI.UTF-8); UI: en-US
Calc: threaded
Built on 3 June 2020
Comment 13 Roman Kuznetsov 2020-06-07 12:27:58 UTC
(In reply to Buovjaga from comment #12)
> I can't reproduce. Florent, Roman: can you please re-test?
> 
> Arch Linux 64-bit
> Version: 7.1.0.0.alpha0+
> Build ID: 2bccbd2ba6c90d5e02285629c2b079c35260c08b
> CPU threads: 8; OS: Linux 5.6; UI render: default; VCL: kf5
> Locale: fi-FI (fi_FI.UTF-8); UI: en-US
> Calc: threaded
> Built on 3 June 2020

not repro in

Version: 7.1.0.0.alpha0+ (x64)
Build ID: 651844c9b122fd8463ad1dde4f9a0200efc345a3
Потоков ЦП: 4; ОС: Windows 10.0 Build 18363; Отрисовка ИП: Skia/Vulkan; VCL: win
Locale: ru-RU (ru_RU); ИП: ru-RU
Calc: threaded

So let's close it as WFM