Bug 125064 - values ≥ 1000 are shown in Liberation Serif if thousands separator is set (with French locale)
Summary: values ≥ 1000 are shown in Liberation Serif if thousands separator is set (wi...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2019-05-01 16:25 UTC by Jean-Baptiste Faure
Modified: 2019-05-17 06:45 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
values ≥ 1000 are shown in black Liberation Serif (14.95 KB, application/vnd.oasis.opendocument.spreadsheet)
2019-05-01 16:28 UTC, Jean-Baptiste Faure
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Baptiste Faure 2019-05-01 16:25:02 UTC
Description:
In the current master, the cells in which the thousands separator is set are shown in Liberation Serif font if the value is greater or equal to 1000.

Steps to Reproduce:
1. Open the attached bugdoc in LO 6.2
2. All cells are shown in blue Carlito 12 font 
3. Open the attached bugdoc in current master: values greater or equal to 1000 are shown in black Liberation Serif 12.
4. Select one from these cells and uncheck "thousands separator" in the cell format (from the right click menu or the tab Properties in the sidebar.
5. the changed cell becomes blue Carlito 12
6. check again "thousands separator" for this cell and it becomes black Liberation Serif 12.


Actual Results:
Thousands separator inhibits the applied format, at least colour and font.

Expected Results:
Thousands separator should not change colour and font and other cell formatting.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 6.3.0.0.alpha0+
Build ID: f7453b956bcf83ec13c805d243f20cb209289179
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Ubuntu_18.04_x86-64
Locale: fr-FR (fr_FR.UTF-8); UI-Language: en-US
Calc: threaded

Best regards. JBF
Comment 1 Jean-Baptiste Faure 2019-05-01 16:28:46 UTC
Created attachment 151117 [details]
values ≥ 1000 are shown in black Liberation Serif
Comment 2 Usama 2019-05-01 20:10:19 UTC
Unable to reproduce, font or colour doesn't change. 

Version: 6.3.0.0.alpha0+
Build ID: c9956772ec0678498515fb60dca41e9a77457f86
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-04-18_19:56:56
Locale: fr-FR (tr_TR.UTF-8); UI-Language: en-US
Calc: threaded
Comment 3 Jean-Baptiste Faure 2019-05-01 20:34:47 UTC
(In reply to Usama from comment #2)
> Unable to reproduce, font or colour doesn't change. 
> 
> Version: 6.3.0.0.alpha0+
> Build ID: c9956772ec0678498515fb60dca41e9a77457f86
> CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk3; 
> TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time:
> 2019-04-18_19:56:56

Thank you for your test. Your build is rather old (18/04), could you test with a newer build?

Best regards. JBF
Comment 4 Aron Budea 2019-05-01 20:41:52 UTC
No repro for me, either, all entries are shown in blue Carlito font.
Used latest build of LO 6.3 Linux bibisect repo.

Version: 6.3.0.0.alpha0+
Build ID: 73df787fe2c66d16cec08d28e383a72fe3855bfd
CPU threads: 16; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 5 Aron Budea 2019-05-01 20:44:11 UTC
Actually, I can repro with locale French (France).
Comment 6 Aron Budea 2019-05-01 20:51:52 UTC
Bibisected to the following commit using repo bibisect-linux-64-6.3, which is the same as bug 125054's starting commit. Adding Cc: to Armin Le Grand, please take a look.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=1e2682235cded9a7cd90e55f0bfc60a1285e9a46
author		Armin Le Grand <Armin.Le.Grand@me.com>	2019-04-18 19:25:06 +0200
committer	Armin Le Grand <Armin.Le.Grand@me.com>	2019-04-25 19:59:04 +0200

WIP: Further preparations for deeper Item changes
Comment 7 Jean-Baptiste Faure 2019-05-17 06:45:58 UTC
Fixed with the current version of the master :

Version: 6.3.0.0.alpha1+
Build ID: acd4625f2f1bf418452ffdafeac1b83fe1b2acde
Threads CPU : 4; OS : Linux 4.15; UI Render : par défaut; VCL: gtk3; 
Ubuntu_18.04_x86-64
Locale : fr-FR (fr_FR.UTF-8); Langue IHM : fr-FR
Calc: threaded

Best regards. JBF