Bug Hunting Session
Bug 125070 - FILEOPEN PPTX for OOXML preset types "pour" the value of the adjustment gets lost
Summary: FILEOPEN PPTX for OOXML preset types "pour" the value of the adjustment gets ...
Status: RESOLVED DUPLICATE of bug 125563
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-05-01 21:51 UTC by Regina Henschel
Modified: 2019-06-07 17:01 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
All four "pour" types shapes with screenshots (165.09 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2019-05-01 21:51 UTC, Regina Henschel
Details
comparison MSO 2010 and LibreOffice 6.3 Master (307.03 KB, image/png)
2019-05-03 15:07 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2019-05-01 21:51:08 UTC
Created attachment 151121 [details]
All four "pour" types shapes with screenshots

Open attached document. It has on the left side shapes and on the right side a screenshot, how it looks in PowerPoint.

The shape types "textArchDownPour", "textArchUpPour", "textButtonPour" and "textCirlePour" looses the values of the adjustment guide ('Handle') on import and default values are used.

If you drag the handles, you can set them to the same position as in the screenshot. So the handle is able to have such position. But the existing values are not read on import.

At first glance, it looks as if these types are missing in the list in https://opengrok.libreoffice.org/xref/core/oox/source/drawingml/shape.cxx?r=fdf4aaa3#579. But I have not tested it yet.
Comment 1 V Stuart Foote 2019-05-02 04:02:39 UTC
Mishandling of word art in LO produced OOXML, confirmed on Windows 10 Pro 64-bit en-US with Word 2016 compared to LO 6.2.3.2
Comment 2 Xisco Faulí 2019-05-03 15:07:06 UTC
Created attachment 151161 [details]
comparison MSO 2010 and LibreOffice 6.3 Master
Comment 3 Xisco Faulí 2019-05-03 15:08:51 UTC
in

Version: 5.3.0.0.beta2+
Build ID: 6238f71ddbdc766e733b1c808a4fa7d66f7bde87
CPU Threads: 4; OS Version: Linux 4.15; UI Render: default; VCL: gtk3; Layout Engine: new; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

they are not even displayed...
Comment 4 Regina Henschel 2019-06-07 16:59:46 UTC
The other transformations have the same error, see bug 125560. Problem will be solved together with them.

*** This bug has been marked as a duplicate of bug 125560 ***
Comment 5 Regina Henschel 2019-06-07 17:01:15 UTC
Oops, wrong number.

*** This bug has been marked as a duplicate of bug 125563 ***