Bug 125097 - Calc crashes when on Data validation->List when using Kvantum theme
Summary: Calc crashes when on Data validation->List when using Kvantum theme
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.3.2 release
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-05-03 06:44 UTC by Mike
Modified: 2019-05-03 07:45 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike 2019-05-03 06:44:14 UTC
Data->Validation->Citeria then I choose List but the moment I do this, LO always crashes. It turned out the bug is happening because of the used Kvantum theme. When I switch or force Breeze theme everything is fine and there is no crash.

Since crashes should happen anyway, I report this bug for further testing.

System:

Operating System: Manjaro Linux 
KDE Plasma Version: 5.15.4
KDE Frameworks Version: 5.57.0
Qt Version: 5.12.3
Kernel Version: 5.0.10-2-MANJARO
OS Type: 64-bit
Processors: 8 × Intel® Core™ i7-6700HQ CPU @ 2.60GHz
Memory: 7,7 GiB

Steps to reproduce:

1. Install Arch/Manjaro with Plasma DE.
2. Install LO 6.2.3-2 (the version I discovered it but it will probably exist on earlier ones and the newer ones till the issue is fixed)
3. Install Kvantum theme manager.
4. Install KvGlassWhite theme in Kvantum theme manager from this site:

https://store.kde.org/p/1240691

5. Set KvGlassWhite in Kvantum manager and in system settings application look for kvantum.

6. When KvGlassWhite is successfully applied on a system, open Calc and go to Data->Validity->Criteria tab-> Choose List from the list
At this point, LO crashes.

When I use Breeze override, all works fine:

QT_STYLE_OVERRIDE=Breeze libreoffice --calc


More info in those topics:

https://forum.manjaro.org/t/lo-always-crashes-when-choosing-data-validation-list-on-plasma/85753

https://ask.libreoffice.org/en/question/192295/solved-data-validation-list-lo-always-crashes/


If more hardware and software info is needed, let me know.
Comment 1 Buovjaga 2019-05-03 07:45:31 UTC
I repro the crash with 6.2.3, but not with a master build. Thus I will close.

Arch Linux 64-bit
Version: 6.2.3.2
Build ID: 6.2.3-2
CPU threads: 8; OS: Linux 5.0; UI render: default; VCL: kde5; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded

Arch Linux 64-bit
Version: 6.3.0.0.alpha0+
Build ID: a0edb53e63b9fa7ed5983d6500aece1e5eff380b
CPU threads: 8; OS: Linux 5.0; UI render: default; VCL: kde5; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 25 April 2019