Bug 125115 - Wrong pie chart's legend when there are gaps in data range
Summary: Wrong pie chart's legend when there are gaps in data range
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Chart-Legends
  Show dependency treegraph
 
Reported: 2019-05-04 13:02 UTC by Roman Kuznetsov
Modified: 2020-06-06 08:13 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
sample file with pie chart (13.82 KB, application/vnd.oasis.opendocument.spreadsheet)
2019-05-04 13:03 UTC, Roman Kuznetsov
Details
Screenshot of the example file (49.45 KB, image/png)
2019-05-06 07:21 UTC, Gabor Kelemen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2019-05-04 13:02:10 UTC
Description:
Wrong pie chart's legend when there are gaps in data range

This bug folows from bug 66327

Steps to Reproduce:
1. Open file from attach
2. Look at legend on chart
3. There is unnecessary item between first and second items

Actual Results:
There is unnecessary item in the legend

Expected Results:
Legend has only necessary items


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Roman Kuznetsov 2019-05-04 13:03:32 UTC
Created attachment 151177 [details]
sample file with pie chart
Comment 2 Gabor Kelemen 2019-05-06 07:21:40 UTC
Created attachment 151196 [details]
Screenshot of the example file

Repro with bibisect-win32-6.3 :

Version: 6.3.0.0.alpha0+
Build ID: 83abdf803a023067ebc207fd82dde987df233754
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
Locale: en-US (hu_HU); UI-Language: en-US
Calc: threaded
Comment 3 Jacques Guilleron 2019-05-30 13:22:16 UTC
Hi Roman, Gabor,

I Observed I get a correct legend by selecting datas this way:
A2, CTRL A4, CTRL B2, CTRL B4

Have a fine day,

Jacques
Comment 4 Aron Budea 2020-06-06 08:13:38 UTC
Same in LO 3.3.0.
Checked the same in Excel 2013, and it behaves the same (not implying whether that should decide if it's regarded as a bug). We can probably lower the severity, though.