Download it now!
Bug 125139 - Ticking / unticking the "Field shadings" checkbox in Options > Application Colors has no effect, while Ctrl+F8 does
Summary: Ticking / unticking the "Field shadings" checkbox in Options > Application Co...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.3.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Options-Dialog
  Show dependency treegraph
 
Reported: 2019-05-06 15:13 UTC by sj
Modified: 2020-01-10 07:21 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sj 2019-05-06 15:13:01 UTC
Description:
Ctrl+F8 successfully switches between displaying a special color for the fields, including non breaking spaces.

The checkbox next to the color picker, in Options > Application Colors, doesn't have any effect when checked / unchecked, even after pressing the "Apply" button.

Interestingly, when the fields are displayed, and one unticks the checkbox, although nothing happens visually, one still has to press Ctrl+F8 TWICE to hide the fields effectively, which seems to imply that some boolean value somewhere is successfully being modified by the ticking / unticking of the checkbox.

Steps to Reproduce:
1. Write some text that includes non breaking spaces
2. Open Tools > Options 
3. Go to LibreOffice > Application Colors
4. Under Custom Colors > Text Document, switch the state of the Field shadings checkbox
5. Click the Apply button


Actual Results:
Nothing changes regarding the aspect of the non breaking spaces

Expected Results:
The non breaking spaces, and other fields, should receive the background color chosen for the Field shadings, or not receive said color, depending on the state of the checkbox.


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
Version: 6.2.3.2
Build ID: 6.2.3-2
CPU threads: 4; OS: Linux 5.0; UI render: default; VCL: gtk3; 
Locale: fr-CH (fr_CH.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Dieter 2019-05-06 20:54:04 UTC
I can't reproduce it with

Version: 6.2.3.2 (x64)
Build-ID: aecc05fe267cc68dde00352a451aa867b3b546ac
CPU-Threads: 4; BS: Windows 10.0; UI-Render: GL; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: threaded

So perhaps only Linux.
Comment 2 Xisco Faulí 2019-06-10 15:35:15 UTC
I can't reproduce it in

Version: 6.4.0.0.alpha0+
Build ID: 43ddddb703bcdb9430752af63ae46527f737f874
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

To be certain the reported issue is not
related to corruption in the user profile, could you please reset your
Libreoffice profile ( https://wiki.documentfoundation.org/UserProfile ) and
re-test?

I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the issue is still present
Comment 3 QA Administrators 2019-12-08 03:46:09 UTC Comment hidden (obsolete)
Comment 4 QA Administrators 2020-01-08 03:31:33 UTC Comment hidden (obsolete)
Comment 5 sdc.blanco 2020-01-09 08:42:56 UTC
Reopening

@Heiko -- here is another check box that might be a candidate for removal.

As noted in OP, the Field Shading checkbox in Options - Libreoffice - Applications Colors does nothing more than the ctrl+f8 toggle. (and this toggle changes the setting in Options, so it does not function as a default when documents are opened).  That is, when a document is opened, it takes the value of the currently open document, so the Options setting has no lasting effect. (similar to the ctrl+F9 case)  (No opinion about keep or not, just noting situation for your consideration.)
Comment 6 Heiko Tietze 2020-01-09 13:31:18 UTC
(In reply to sdc.blanco from comment #5)
> Reopening
> 
> @Heiko -- here is another check box that might be a candidate for removal.
> 
> As noted in OP, the Field Shading checkbox in Options - Libreoffice -
> Applications Colors does nothing more than the ctrl+f8 toggle. (and this
> toggle changes the setting in Options, so it does not function as a default
> when documents are opened).  That is, when a document is opened, it takes
> the value of the currently open document, so the Options setting has no
> lasting effect. (similar to the ctrl+F9 case)  (No opinion about keep or
> not, just noting situation for your consideration.)

Different case here IMHO. With the application color you may change the default grey background of fields into red or whatever. The checkbox next to it might be removed but it also doesn't hurt at all.
Comment 7 sdc.blanco 2020-01-09 16:43:45 UTC
(In reply to Heiko Tietze from comment #6)
> The checkbox next to it might be removed but it also doesn't hurt at all.
My query was only about the checkbox. (same as in the OP). 
("Field codes" was removed - because it didn't do anything useful.)  
Same situation here. I guess NEW or WONTFIX.  Your choice.
Comment 8 Heiko Tietze 2020-01-10 07:21:03 UTC
WFM since apply works as expected in 6.2.8.2