Bug Hunting Session
Bug 125147 - Digital Signatures for DOCX files
Summary: Digital Signatures for DOCX files
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.2.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: Digital-Signatures
  Show dependency treegraph
 
Reported: 2019-05-06 22:29 UTC by Sheldon
Modified: 2019-06-05 09:24 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sheldon 2019-05-06 22:29:38 UTC
Description:
We can add digital signatures to odt files but are unable to add digital signatures to docx files. Some require files sent in the docx format; not PDF or ODT. Therefore, being able to add a digital signature to these files is important.

Steps to Reproduce:
Click Digital Signatures
Sign Document
No saved PGP keys are in the list. No way to sign the DOCX file. 
If file is in ODT, two saved keys are in the list.

Actual Results:
Cannot sign DOCX documents

Expected Results:
Sign DOCX document.


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
Sign the DOCX document with an existing, or recently created, key
Comment 1 Heiko Tietze 2019-06-01 08:13:56 UTC
Not really a UX topic (removing the flag). 

Miklos, what do you think?
Comment 2 Miklos Vajna 2019-06-03 07:26:36 UTC
Signing with X509 certs works fine for me for DOCX files.

Samuel: is it possible gpg vs docx is not working? No idea if that's just a matter of development work or it's impossible due to what OOXML allows.
Comment 3 Samuel Mehrbrodt (CIB) 2019-06-04 06:17:41 UTC
This is intentional, OOXML doesn't allow signing with PGP keys (Word would not open them) afaik.