Bug Hunting Session
Bug 125185 - Hidden cells also get contents pasted
Summary: Hidden cells also get contents pasted
Status: RESOLVED DUPLICATE of bug 36466
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-05-09 07:08 UTC by Rainer Bielefeld Retired
Modified: 2019-05-16 11:38 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2019-05-09 07:08:18 UTC
Steps how to reproduce with  server installation of Version: 6.3.0.0.alpha0+ 
Build ID: 2e3b0c5d42d60d46cd9f8b8eda9424b095c63418; Windows 6.1:

0. Create a minimum Spreadsheet with single column containing values 1, 2, 3
1. ˋClick → Rightclick on row heading for row containing "2" → Hide rowˊ
    » row disappears
2. ˋRightclick on Cell containing "1" → Copyˊ
3. Select / Mark Cells containing  numbers "1" and "3" using mouse pointer
    » Both cells highlighted
4. ˋRightclick Cell containing "3" → Pasteˊ
    » Both cells show "1"
5. Select both rows containing  "1" by selecting both row headings using mouse
    » both rows highlighted
6. ˋRightclick one of the highlighted page headers → showˊ
    » hidden row appears
    Expected: column shows 1, 2, 1
    Actual:       column shows 1, 1, 1              😥

Similar problem has been fixed for Bug 35345 - Cells hidden with filters get changed
I can't see any reason why there should be different behavior between rows hidden by filter and rows hidden by 'Hide'
Comment 1 Oliver Brinzing 2019-05-09 17:08:29 UTC
i can confirm this behaviour, but isn't it the same like excel 2016 does?
Comment 2 Rainer Bielefeld Retired 2019-05-12 08:09:36 UTC
(In reply to Oliver Brinzing from comment #1)
May be, but I consider that behavior as a bug. It is completely unexpected that hidden cells become modified (sometimes and sometimes not).
Comment 3 Timur 2019-05-13 13:09:20 UTC
This was a request. It's not behavior that should be confirmed, but change. So it was wrongfully confirmed without UXeval.

My opinion is that this should not be accepted. Hidden is not the same as filtered out. 
Solution is to have *an option* not to select hidden cells i.e. to select visible cells only but that's bug 36466. I'll mark this one a a duplicate.

There's the extension https://extensions.libreoffice.org/extensions/copy-only-visible-cells but it's logic is also not complete, it copies visible cells but it should instead just select visible cells. Copying to or from can than be done as usual.

*** This bug has been marked as a duplicate of bug 36466 ***
Comment 4 Heiko Tietze 2019-05-13 13:42:20 UTC
(In reply to Timur from comment #3)
> Solution is to have *an option* not to select hidden cells...

Accepted. Removing UX again since this does not need discussion.
Comment 5 Rainer Bielefeld Retired 2019-05-13 18:41:03 UTC
Real Life User Scenario for this decision is missing. I can't imagine any reason why hidden cells (does not matter hidden by what operation should) be modified.

Tired with this.
Comment 6 Heiko Tietze 2019-05-16 11:38:42 UTC
(In reply to Rainer Bielefeld Retired from comment #5)
> Tired with this.

Don't be. We have both situations the one where users are not aware of hidden cells and overriding or not is awkward and the opposite when they expect a particular behaviour. Isn't the best solution to make them aware of this?