Download it now!
Bug 125195 - Compare documents crashes
Summary: Compare documents crashes
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Track-Changes
  Show dependency treegraph
 
Reported: 2019-05-09 13:44 UTC by Luke Kendall
Modified: 2019-05-09 14:08 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Two sample documents that will crash with 6.2.0 if compared (1.34 MB, application/zip)
2019-05-09 13:44 UTC, Luke Kendall
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luke Kendall 2019-05-09 13:44:18 UTC
Created attachment 151273 [details]
Two sample documents that will crash with 6.2.0 if compared

If I compare two versions of my manuscript in LO, writer crashes.

I thought I'd try the feature again, despite https://bugs.documentfoundation.org/show_bug.cgi?id=102616, in the hope that problem might have been fixed.

It hasn't (after recovering from the crash, almost the entire document is marked as changed, despite the changes to the *text* being relatively small), as 99% of the text is marked as different.

But as well, now LO crashes when I try to compare them.

Steps to reproduce:

1. Open the provided (obfuscated) MS VC-obfusc-4x7.odt
2. Compare with document VC-obfusc-5x8.odt

Results:

LO instantly crashes.

I'm only reporting this for your interest, because while filling out the bug report I downloaded and installed LO 6.2.3.2, and I'm glad to say the crashing bug has been fixed.

If other users of 6.2.0.3 suffer the same problem, at least they'll know an upgrade to 6.2.3.2 will fix the crashing.
Comment 1 Dieter 2019-05-09 14:05:20 UTC
(In reply to Luke Kendall from comment #0)
 
> I'm only reporting this for your interest, because while filling out the bug
> report I downloaded and installed LO 6.2.3.2, and I'm glad to say the
> crashing bug has been fixed.

Yes, I remember such a bug report, but I couldn't find it.

=> RESOLVED WORKSFORME