Bug 125258 - libreoffice doesn't respect french typography concerning ":"
Summary: libreoffice doesn't respect french typography concerning ":"
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.2.7.2 release
Hardware: All Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-05-13 10:11 UTC by Stéphane Aulery
Modified: 2021-05-16 19:30 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stéphane Aulery 2019-05-13 10:11:59 UTC
Dear Maintainer,

all is said in the title of this bug report : when typing the following 
character of a ":" character, the space before the ":" character disappears 
and there is no space after.
This bug also affects the last version of LibreOffice.

Thanks for your help.
Comment 1 Julien Nabet 2019-05-13 15:33:10 UTC
On Win10 with master sources updated today, I could reproduce this.

Jean-Baptiste/Sophie: thought you might be interested in this one, so put you in cc so you're informed about evolutions of this issue.
Don't hesitate to uncc if don't want to/no time/etc.
Comment 2 sophie 2019-05-13 15:47:33 UTC
Could you check that Dicollecte (https://grammalecte.net/) is installed? it should be shipped with the version and it handles unbreakable spaces.
Comment 3 Julien Nabet 2019-05-13 16:04:14 UTC
Sophie: thank you for your quick feedback, I got the same behaviour with Grammalecte (last version 1.0.2).
Comment 4 Stéphane Aulery 2019-05-13 16:22:30 UTC
No information about dicollecte installation. I try to have this information from the reporter.
Comment 5 sophie 2019-05-13 16:29:19 UTC
I've added Olivier, Grammalecte developer in cc. I could not reproduce on Linux Version: 6.2.2.2
Olivier, could you have a look?
Comment 6 Jean-Baptiste Faure 2019-05-14 07:29:23 UTC
Not reproducible for me under Linux / Ubuntu with LO 6.2 and current master.

Version: 6.3.0.0.alpha0+
Build ID: 7cfacfd4e990d5b8fd2cb3045cf632b9dd957023
Threads CPU : 4; OS : Linux 4.15; UI Render : par défaut; VCL: gtk3; 
Ubuntu_18.04_x86-64
Locale : fr-FR (fr_FR.UTF-8); Langue IHM : fr-FR
Calc: threaded

Did you check AutoCorrect options? In French : Menu Outils > AutoCorrection > Onglet Options linguistiques.

Did you check that your text is formatted as French?

Best regards. JBF
Comment 7 Julien Nabet 2019-05-14 07:45:35 UTC
(In reply to Jean-Baptiste Faure from comment #6)
> ...
> Did you check that your text is formatted as French?
> ...
I checked this too, it's formatted as French.
However, I didn't test on my Linux machine, will do this to compare.
Comment 8 Jean-Baptiste Faure 2019-05-14 07:55:10 UTC
What component is affected? I assumed that it was Writer. Just checked in Calc, Impress and Draw and I do not reproduce the problem in these components too with the master.

Best regards. JBF
Comment 9 Julien Nabet 2019-05-14 08:25:04 UTC
(In reply to Jean-Baptiste Faure from comment #8)
> What component is affected? I assumed that it was Writer. Just checked in
> Calc, Impress and Draw and I do not reproduce the problem in these
> components too with the master.
> 
> Best regards. JBF

I used Writer for my tests but using Calc and Impress gave the same results.
Since master sources are building right now, I'm using LO 6.1.5 on Win10.
ASAP, I'll upgrade to 6.2.3 and give it a try
Comment 10 Laurent BP 2019-05-14 17:54:04 UTC
Could you give a precise procedure. If I type
Toto:
I correctly get
Toto :
with a non-breaking space, for a text in French and Tools > AutoCorrect > AutoCorrect Options, tab Localized Options, check "Add non-breaking space..."
(Outils > AutoCorrection > Options d'AutoCorrection, onglet Options linguistiques, cocher "Ajouter un espace insécable...")
Comment 11 Julien Nabet 2019-05-14 19:16:30 UTC
(In reply to Laurent BP from comment #10)
> Could you give a precise procedure. If I type
> Toto:
> I correctly get
> Toto :
> with a non-breaking space, for a text in French and Tools > AutoCorrect >
> AutoCorrect Options, tab Localized Options, check "Add non-breaking space..."
> (Outils > AutoCorrection > Options d'AutoCorrection, onglet Options
> linguistiques, cocher "Ajouter un espace insécable...")

If I just type "T" "o" "t" "o" ":",
I got indeed "Toto : "(with unbreakable space just before colon.

Now if I type "T" "o" "t" "o" ":" "a"
I got "Toto:a" instead of "Toto : a".

I just reproduced this on pc Debian x86-64 with master sources updated today + brand new profile + French locale ui

[R] and [S]  checkboxes for "Ajouter un espace insécable avant les signes de ponctuation spécifiques dans les textes français." are checked.
Comment 12 Laurent BP 2019-05-14 19:26:05 UTC
(In reply to Julien Nabet from comment #11)
> Now if I type "T" "o" "t" "o" ":" "a"
> I got "Toto:a" instead of "Toto : a".
> 
> I just reproduced this on pc Debian x86-64 with master sources updated today
> + brand new profile + French locale ui
> 
> [R] and [S]  checkboxes for "Ajouter un espace insécable avant les signes de
> ponctuation spécifiques dans les textes français." are checked.

OK thanks for the precision. 
I do reproduce and it works as expected, from my point of view, and from a long time ago. You need to type a soft or hard space after your ':' to keep the inserted hard space. It enables user to type URL without pain for instance.

Not a bug for me.
Comment 13 Jean-Baptiste Faure 2019-05-14 19:37:30 UTC
I agree with Laurent, it is not a bug, it's a feature ;-) Indeed it is the feature that allows you to type for example hyperlinks like https://wwww... 
When I type toto, then the colon then the character a, I see first the auto-correction in "toto :" then this auto-correction is cancelled when I type a non-blank character just after the colon.

@Stéphane: is this particular use-case that motivated your bug report?

Best regards. JBF
Comment 14 QA Administrators 2021-05-14 04:09:33 UTC Comment hidden (obsolete)
Comment 15 Jean-Baptiste Faure 2021-05-16 11:22:34 UTC
From comment #13 this bug report should be in NEEDINFO state.

Status has been set to NEEDINFO, please set it back to UNCONFIRMED once requested information has been provided.


Best regards. JBF
Comment 16 Stéphane Aulery 2021-05-16 12:01:18 UTC
@Stéphane: is this particular use-case that motivated your bug report?

No, I did bug triage on Debian and reported upstream. The original report didn't talk about links.
Comment 17 Jean-Baptiste Faure 2021-05-16 14:55:46 UTC
(In reply to Stéphane Aulery from comment #16)
> @Stéphane: is this particular use-case that motivated your bug report?
> 
> No, I did bug triage on Debian and reported upstream. The original report
> didn't talk about links.

Ok, so closing this one as WorksForMe because nobody reproduced the problem when typing a space after a colon. The case a:a is not a bug, it is a feature allowing to type "words" like URL.

Feel free to reopen if you disagree. In that case please provide a clear step by step scenario reproducing the behavior.

Best regards. JBF
Comment 18 Stéphane Aulery 2021-05-16 19:30:41 UTC
I think we did it all. I bring up the information.