Bug 125266 - Hang when selecting Read Online Help (GTK2)
Summary: Hang when selecting Read Online Help (GTK2)
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha1+
Hardware: All All
: high major
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.3.0 target:6.2.5
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2019-05-13 16:10 UTC by Xisco Faulí
Modified: 2019-05-17 11:27 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2019-05-13 16:10:22 UTC
This is a follow-up of bug 125208 happening after https://cgit.freedesktop.org/libreoffice/core/commit/?id=5f755c6455684338ccdedacdd560e1188e7fca76 only with GTK2


Steps to reproduce:

1. Start any module (Writer, Calc, etc) or open Start Center and Create a new document of any kind (from menu or button) or open any document
2. Click on menu Help, LibreOffice Help and then on any option (Read Help Online or Cancel)

Result
LibreOffice hangs

Reproduced in

Version: 6.3.0.0.alpha0+
Build ID: 630db80d17616d635cf2e5f1d5a0852428b794a3
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk2; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Xisco Faulí 2019-05-13 16:16:01 UTC
it started to crash after https://cgit.freedesktop.org/libreoffice/core/commit/?id=3a4a90e6e59e16e2ea0883caba87e114a07642f3 ( bug 125208 ) then the crash was fixed in https://cgit.freedesktop.org/libreoffice/core/commit/?id=5f755c6455684338ccdedacdd560e1188e7fca76 when it started to hang

Adding Cc: to Caolán McNamara
Comment 2 Commit Notification 2019-05-14 16:33:01 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/4cac171dd6c82f55624ba6e7185d69bcb5507cb1%5E%21

Resolves: tdf#125266 hang on selecting read online help

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Commit Notification 2019-05-14 20:13:32 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/c9b31caf3a33618dd2c9272bb528f8567b428fe5%5E%21

Related: tdf#125266 set default dialog parent for SfxHelp

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Xisco Faulí 2019-05-16 08:33:11 UTC
Hi Caolán,
I do confirm the issue is fixed in

Version: 6.3.0.0.alpha1+
Build ID: a3e649c3384d19a5ad540c3d65d5f79b66fd9090
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk2; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

I've also played around with other dialogs and I couldn't find any wrong behaviour.
Can the commits be backported to 6.2 branch ?
Comment 5 Caolán McNamara 2019-05-16 09:27:24 UTC
sounds good, fixed in master then, and https://gerrit.libreoffice.org/#/c/72400/ for 6-2
Comment 6 Commit Notification 2019-05-16 11:40:41 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/cde86a07bdd3534f75ec94955837812e2bbd24d4%5E%21

Resolves: tdf#125266 hang on selecting read online help

It will be available in 6.2.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.