Bug 125285 - NB sd modules wrong usage of ObjectForwardOne, ObjectBackOne
Summary: NB sd modules wrong usage of ObjectForwardOne, ObjectBackOne
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
6.0.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.3.0 target:6.2.5
Keywords:
: 125188 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-05-14 14:35 UTC by andreas_k
Modified: 2019-05-15 02:46 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description andreas_k 2019-05-14 14:35:06 UTC
Description:
Forward One Back One didn't work in NB in draw and impress.

Actual Results:
ObjectForwardOne
ObjectBackOne

Expected Results:
Forward
Backward

will work.


Reproducible: Always


User Profile Reset: No



Additional Info:
I submit the bugfix and will backport it.
Comment 1 andreas_k 2019-05-14 14:45:46 UTC
*** Bug 125188 has been marked as a duplicate of this bug. ***
Comment 2 Roman Kuznetsov 2019-05-14 16:09:06 UTC
https://gerrit.libreoffice.org/#/c/72296/
Comment 3 Commit Notification 2019-05-14 19:44:41 UTC
andreas kainz committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/ac9a59cb77c8ed7d5e2a0bc22787c56b90511271%5E%21

tdf#125285 Use Forward Backward instead of ObjectForwardOne/BackOne

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2019-05-15 02:46:57 UTC
andreas kainz committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/54a5e8cb12b580a433ec7e8221b44af08dc7d6ad%5E%21

tdf#125285 Use Forward Backward instead of ObjectForwardOne/BackOne

It will be available in 6.2.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.