Bug 125305 - Font type is changed in new Calc 6.3+ file while editing cell from 'liberation sans' to 'liberation serif'
Summary: Font type is changed in new Calc 6.3+ file while editing cell from 'liberatio...
Status: RESOLVED DUPLICATE of bug 125054
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks:
 
Reported: 2019-05-15 10:52 UTC by b.
Modified: 2019-05-18 20:11 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description b. 2019-05-15 10:52:24 UTC
Description:
hi @all,

since some weeks the font used / shown while! editing a cell is different from that applied to that cell.

e.g. on input to an empty or editing a filled cell (doubleclick or 'F2') the font for the shown content and the font name in the white box in the upper left corner change from 'liberation sans' to 'liberation serif'.

after pressing enter or changing to another cell the font is changed back in most cases, bur i observed rare cases where the change is kept after confirmation.

is this 'by design', or a bug (e.g. reg. comparing or selecting fonts with '<' than '<=') ?

affected are some alpha0 and the actual alpha1 version of LO 6.3.

reg.

b.


Steps to Reproduce:
just look on the typeface of the characters when editing a cell

Actual Results:
changed

Expected Results:
don't know, is the change intentional? 


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.3.0.0.alpha1+ (x64)
Build ID: e92dcfdc7bd7b237e0bee26ff226a102d9e8e766
CPU threads: 8; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-05-14_00:00:57
Locale: de-DE (de_DE); UI-Language: en-US
Calc: *unthreaded*
Comment 1 Timur 2019-05-15 11:05:27 UTC
Repro. Let's see via bibisect when this started.
Comment 2 Roman Kuznetsov 2019-05-18 20:11:56 UTC

*** This bug has been marked as a duplicate of bug 125054 ***