Bug 125306 - Shortcut Ctrl+Shift+; work uncorrectly with JP keyboard
Summary: Shortcut Ctrl+Shift+; work uncorrectly with JP keyboard
Status: RESOLVED DUPLICATE of bug 126888
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.3.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Shortcuts-Locale
  Show dependency treegraph
 
Reported: 2019-05-15 10:56 UTC by zexcel
Modified: 2019-08-15 18:35 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Standard Japanese 109 keyboard (230.75 KB, image/jpeg)
2019-05-18 12:52 UTC, zexcel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description zexcel 2019-05-15 10:56:11 UTC
Description:
Repeat the bugs 32475, 88027 and 122918.
Ctrl+Shift+; is expected to insert current time, however, cell is inserted instead, for Shift+; assign to key"+" in Japanese layout.
I can change to Ctrl+. shortcut to insert current time. Actally, I want to use Ctrl+: shortcut to compatible with excel experince, however it is not in the shortcut list.
By the way, The shortcut Ctrl+; insert current date correctly. 

Steps to Reproduce:
1.Ctrl+Shift+;  in a calc cell
2.
3.

Actual Results:
cell added

Expected Results:
insert current time


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Julien Nabet 2019-05-15 20:23:44 UTC
Could you attach the layout of your keyboard? Taking a look at https://en.m.wikipedia.org/wiki/Language_input_keys, thought colon and sem colon would be on 2 different keys
Comment 2 zexcel 2019-05-18 12:52:17 UTC
Created attachment 151497 [details]
Standard Japanese 109 keyboard

This is a standard Japanese keyboard.
Popular name is 109 keys Japanese keyboard.
Special designed Japanese Characters Input keys are created by shorted the space key.
Comment 3 Julien Nabet 2019-05-20 14:13:52 UTC
Thank you zexcel for your feedback.
I tried to understand Youfuf's patch from tdf#88027 but am lost between localized keyboard layouts, English keyboard layout (eg: according to tdf#122918, Russian part is ok but only if English layout used), localized shortcuts of Excel to copycat, etc. 
Uncc myself since I can't help here.
Comment 4 Xisco Faulí 2019-08-15 18:35:47 UTC
it seems to be the same problem as in bug 126888

*** This bug has been marked as a duplicate of bug 126888 ***