Bug 125360 - PPTX: Shape fill transparency is not exported if the original shape fill is defined with a theme
Summary: PPTX: Shape fill transparency is not exported if the original shape fill is d...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Tamás Zolnai
URL:
Whiteboard: target:6.3.0 target:6.2.5
Keywords:
Depends on:
Blocks:
 
Reported: 2019-05-18 15:50 UTC by Tamás Zolnai
Modified: 2019-05-21 08:33 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Test document with a single shape (15.02 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2019-05-18 15:53 UTC, Tamás Zolnai
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tamás Zolnai 2019-05-18 15:50:44 UTC
Description:
LibreOffice has a few issues with MSO theme handling. One issue is that the user can't change a shape fill transparency because the imported color is stored by LO and used by export.

Steps to Reproduce:
1. Open attached PPTX
2. Change fill transparency of the shape on the first slide.
3. Save the file into PPTX
4. Reopen the file -> no transparency is imported

Actual Results:
The set transparency (in step 2) is not saved.

Expected Results:
The set transparency (in step 2) should be saved and imported back correctly.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Tamás Zolnai 2019-05-18 15:53:46 UTC
Created attachment 151505 [details]
Test document with a single shape
Comment 2 Xisco Faulí 2019-05-20 13:37:41 UTC
Reproduced in

Version: 6.3.0.0.alpha1+
Build ID: 9c7fac47aacb0877c7d212217089a680400c1377
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

and

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 3 Commit Notification 2019-05-20 14:47:23 UTC
Tamás Zolnai committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/259d01a34d27df2fbfd11c3bf6fe9dc508ff6ac2%5E%21

tdf#125360: PPTX: Shape fill transparency is not exported

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2019-05-21 06:03:27 UTC
Tamás Zolnai committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/5e3a3e7d37aecd353ebab78f24e7b32a66a7df83%5E%21

tdf#125360: PPTX: Shape fill transparency is not exported

It will be available in 6.2.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.