Bug Hunting Session
Bug 125391 - Tip of the Day dialog has different default controls for tips with and without links, making different behaviour for simply pressing Enter
Summary: Tip of the Day dialog has different default controls for tips with and withou...
Status: RESOLVED DUPLICATE of bug 125871
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Tip-Of-The-Day
  Show dependency treegraph
 
Reported: 2019-05-20 14:17 UTC by Mike Kaganski
Modified: 2019-09-06 07:12 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Kaganski 2019-05-20 14:17:53 UTC
When a tip of the day contains a hyperlink, the link is selected by default; when there's no link, "Show tips on startup" checkbox is default-selected. For the latter case, simply pressing Enter closes the dialog; for the former, on Windows, it seems to press, while on Linux, it's reported to open the tip in the browser (erAck).

While the different behaviour of controls is a bug of its own, this specific issue is about the need to explicitly pre-select OK in the Tip of the Day dialog (or arguably "Show tips on startup"), for consistent behaviour, without unintended effects on keypress.
Comment 1 raal 2019-05-21 04:38:27 UTC
Confirm
Comment 2 Heiko Tietze 2019-05-22 15:12:58 UTC
We should always focus on the Ok button.
Comment 3 Heiko Tietze 2019-09-06 07:12:09 UTC

*** This bug has been marked as a duplicate of bug 125871 ***