Bug 125403 - The tabs of the layer tabbar are much too wide in Draw without the protect icon
Summary: The tabs of the layer tabbar are much too wide in Draw without the protect icon
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 124572
  Show dependency treegraph
 
Reported: 2019-05-20 23:38 UTC by Regina Henschel
Modified: 2019-08-29 22:03 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of layer tabbar in Draw, compare old and new design (45.80 KB, image/png)
2019-05-20 23:38 UTC, Regina Henschel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2019-05-20 23:38:49 UTC
Created attachment 151543 [details]
Screenshot of layer tabbar in Draw, compare old and new design

With introducing a 'protect' icon in the tabbar of Calc, the layer tabbar in Draw has got much too wide tabs. The whitespace of the labels it too large. Previously we had whitespace of about three 'm's from end of label to the start of the next label. Now there are about seven 'm's between. The effect is, that user defined tabs are no longer directly reachable.

Calc has a derived class for its tabbar. So providing room for the 'protect' icon could be done there. 

The screen shot shows the tabbar of LO 6.1 in the lower part and the current tabbar in the upper part.
Comment 1 m.a.riosv 2019-05-21 08:30:29 UTC
Hi Regina, please see https://wiki.documentfoundation.org/ReleaseNotes/6.3#Calc.2FDraw_tabs
I think it's a duplicate of tdf#124572
Comment 2 Regina Henschel 2019-05-21 11:45:30 UTC
It is like bug 124572 and bug 125378, only that this is for Draw and not for Calc. You are right, that "too large space" is common between Calc and Draw. But Draw and Basic IDE (the other user of that class), have the additional problem, that the space for the 'protect' icon is not needed at all, because that icon only exists in Calc.
Comment 3 Xisco Faulí 2019-05-21 12:32:21 UTC
This changed in https://cgit.freedesktop.org/libreoffice/core/commit/?id=fad98c8641342a77241124dd98e0cb781daef4ad, thus, dupe of 124572

*** This bug has been marked as a duplicate of bug 124572 ***
Comment 4 Xisco Faulí 2019-05-21 12:34:44 UTC
Moving back to UNCONFIRMED after re-reading comment 2. Adding UX team to make them decide
Comment 5 Heiko Tietze 2019-05-22 14:47:05 UTC
Let's block the other ticket. Tomaz wrote, it's not yet finsihed.
Comment 6 Regina Henschel 2019-06-07 16:56:02 UTC
The distance between the labels is OK now in Draw and in Basic IDE. I have tested with Version: 6.4.0.0.alpha0+ (x64)
Build ID: c30ea50dd2b1c557dfbefc1a4c660fbf2402a604
CPU threads: 8; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-06-05_00:23:26
Locale: de-DE (en_US); UI-Language: en-US
Calc: threaded
Comment 7 Thomas Lendo 2019-08-29 22:03:54 UTC
Changing status to WORKSFORME according to comment 6 and after testing Version: 6.3.0.4
Build ID: 057fc023c990d676a43019934386b85b21a9ee99
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: de-AT (de_AT.UTF-8); UI-Language: en-US