Bug Hunting Session
Bug 125506 - Helplines and snap guides no longer visible on macOS (antialising)
Summary: Helplines and snap guides no longer visible on macOS (antialising)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: All Mac OS X (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard: target:6.3.0 target:6.4.0 target:6.3....
Keywords: bibisected, bisected, regression
: 125727 126057 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-05-26 19:07 UTC by Thorsten Wagner
Modified: 2019-06-25 06:35 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of Impress toolbar (16.75 KB, image/png)
2019-05-31 00:18 UTC, Thorsten Wagner
Details
Screenshot of an Impress slide with a single line (79.99 KB, image/png)
2019-05-31 19:44 UTC, Thorsten Wagner
Details
Impress presentation containing a single slide with a single line (9.84 KB, application/vnd.oasis.opendocument.presentation)
2019-05-31 19:45 UTC, Thorsten Wagner
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thorsten Wagner 2019-05-26 19:07:51 UTC
Helplines and snap guides no longer visible on macOS although their visibility is selected in View / Grid and Helplines, View / Snap Guides. Impress and Draw are affected.

Issue exists using macOS. Using Linux helplines and snap guides are displayed correctly. It seems to be a regression.
Comment 1 Thorsten Wagner 2019-05-26 19:33:25 UTC
Steps to reproduce:

(1) Open an empty document with Impress

(2) Select View / Grid and Helplines / Helplines While Moving

(3) Draw an object, e.g. a rectangle

(4) Drag object to another position

Current behaviour:

No helplines are visible while dragging.

Expected behaviour:

Helplines are visible while dragging.
Comment 2 Alex Thurgood 2019-05-27 09:08:26 UTC
Confirming with 

Version: 6.3.0.0.alpha0+
Build ID: dfae42730911256dceb8369528ee9d9944a0fa3e
CPU threads: 4; OS: Mac OS X 10.14.4; UI render: default; VCL: osx; 
Locale: fr-FR (fr_FR.UTF-8); UI-Language: en-US
Calc: threaded
Comment 3 Xisco Faulí 2019-05-30 13:37:27 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=b9fa01a8d1137a95af9865a3e47995734c40da6e

author	Armin Le Grand <Armin.Le.Grand@cib.de>	2018-08-24 13:01:08 +0200
committer	Armin Le Grand <Armin.Le.Grand@cib.de>	2018-08-30 19:48:46 +0200
commit	b9fa01a8d1137a95af9865a3e47995734c40da6e (patch)
tree	6d1e0a3e44b1a96fe5302d779c00fbee55cf8d24
parent	f4a9ce33415a85d0b86ced3a0bf780f4ec61e25f (diff)
Support buffering SystemDependent GraphicData

Bisected with: bibisect-mac64-6.2

Adding Cc: to Armin Le Grand
Comment 4 Xisco Faulí 2019-05-30 22:55:44 UTC
Only happening with antialising
Comment 5 Xisco Faulí 2019-05-30 23:01:42 UTC
Patch in gerrit: https://gerrit.libreoffice.org/#/c/73226/
Comment 6 Thorsten Wagner 2019-05-31 00:08:30 UTC
Helplines as well as snap guides are back using the patch.
Comment 7 Thorsten Wagner 2019-05-31 00:18:56 UTC
Created attachment 151792 [details]
Screenshot of Impress toolbar
Comment 8 Thorsten Wagner 2019-05-31 00:19:52 UTC
Now there is a strange effect concerning selected icons of toolbars (see screenshot).
Comment 9 Xisco Faulí 2019-05-31 08:26:12 UTC
(In reply to Thorsten Wagner from comment #8)
> Now there is a strange effect concerning selected icons of toolbars (see
> screenshot).

Hi Thorsten,
How do you reproduce that effect? OTOH, could you please double check it's caused by my change ?
Comment 10 Xisco Faulí 2019-05-31 09:51:38 UTC
Ok, I do confirm the problem with the buttons...
Comment 11 Xisco Faulí 2019-05-31 10:28:57 UTC
Second patch in gerrit: https://gerrit.libreoffice.org/#/c/73249/, this also fixes bug 121241. 2 birds with one stone :D
Comment 12 Commit Notification 2019-05-31 12:32:58 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/16091ff88aaab9ba9103c4e369bf79b97f431f40%5E%21

tdf#125506 tdf#121241: No need to transform to DeviceCoordinates

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Thorsten Wagner 2019-05-31 19:43:53 UTC
Unfortunately there are further side effices. At least drawing with Impress does not work correctly now.

Please find attached an Impress presentation with a single line 1 pt wide:

(1) Line is shown much too wide after opening.

(2) After selecting and moving a box without the line remains at old position (see screenshot).

Issue is no longer visible after reverting commit.
Comment 14 Thorsten Wagner 2019-05-31 19:44:42 UTC
Created attachment 151813 [details]
Screenshot of an Impress slide with a single line
Comment 15 Thorsten Wagner 2019-05-31 19:45:20 UTC
Created attachment 151814 [details]
Impress presentation containing a single slide with a single line
Comment 16 Xisco Faulí 2019-06-01 17:57:09 UTC
Hi Thorsten,
Thanks for the exhaustive testing.
I've just submitted a new patch to gerrit: https://gerrit.libreoffice.org/#/c/73319/

Could you please test it before I push it to master? the original problem from this bug, the drawing problem and bug 121241 are fixed but maybe I'm breaking something else. I'm not a developer so I'm doing my best here.
Comment 17 Thorsten Wagner 2019-06-01 22:35:08 UTC
It seems to work now. Many thanks for fixing that severe issue.
Comment 18 Commit Notification 2019-06-02 10:14:36 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/93477d1a963e38e3319013e43835a8ffef200972%5E%21

tdf#125506: use rObjectToDevice if needed

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 Xisco Faulí 2019-06-02 10:16:21 UTC
(In reply to Thorsten Wagner from comment #17)
> It seems to work now. Many thanks for fixing that severe issue.

Thanks for checking. I'll cherry-pick it to 6-3 and 6-2 branches
Comment 20 Commit Notification 2019-06-03 13:19:28 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/0236e29bd0197e96e63bc784e6a581e50b022752%5E%21

tdf#125506: use rObjectToDevice if needed

It will be available in 6.3.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 21 Commit Notification 2019-06-04 08:22:31 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/b6a3d0566628e2d8416708d0410193435a3b8e53%5E%21

tdf#125506 tdf#121241: only use rObjectToDevice if needed

It will be available in 6.2.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 22 Xisco Faulí 2019-06-06 07:25:43 UTC
*** Bug 125727 has been marked as a duplicate of this bug. ***
Comment 23 Alex Thurgood 2019-06-25 06:35:52 UTC
*** Bug 126057 has been marked as a duplicate of this bug. ***