Download it now!
Bug 125510 - Sifr: Missing icons within Impress' Display Views drop down box
Summary: Sifr: Missing icons within Impress' Display Views drop down box
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha1+
Hardware: All All
: medium trivial
Assignee: Rizal Muttaqin
URL:
Whiteboard: target:7.0.0 target:6.4.2 target:6.4.4
Keywords:
Depends on:
Blocks: Icon-Theme-Sifr
  Show dependency treegraph
 
Reported: 2019-05-26 20:57 UTC by Thorsten Wagner
Modified: 2020-04-26 12:28 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot (80.18 KB, image/png)
2019-05-26 20:59 UTC, Thorsten Wagner
Details
Sifr icons for Impres display modes toolbox -- current master/6.3.0alpha1+ (32.76 KB, image/png)
2019-05-27 08:44 UTC, V Stuart Foote
Details
Screenshot 1 (19.61 KB, image/png)
2019-07-22 10:59 UTC, Thorsten Wagner
Details
Screenshot 2 (128.48 KB, image/png)
2019-07-22 10:59 UTC, Thorsten Wagner
Details
Screenshot 3 (123.10 KB, image/png)
2019-07-22 11:00 UTC, Thorsten Wagner
Details
Screenshot 4 (42.44 KB, image/png)
2020-02-24 00:18 UTC, Thorsten Wagner
Details
Screenshot 5 (29.18 KB, image/png)
2020-02-24 00:18 UTC, Thorsten Wagner
Details
Screenshot 6 (14.23 KB, image/png)
2020-02-24 00:18 UTC, Thorsten Wagner
Details
Screenshot 7 (203.15 KB, image/png)
2020-02-24 00:19 UTC, Thorsten Wagner
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thorsten Wagner 2019-05-26 20:57:59 UTC
Description:
Icon "Display Views" missing within Impress' toolbar (see screenshot) while using Sifr icon set. Icons for the different types of views seem to be missing too.

Steps to Reproduce:
(1) Open Impress

Actual Results:
Icon "Display Views" as well as icons for view types are missing and replaced by icons from other icon sets.

Expected Results:
Sifr contains "Display View" icon as well as icons for view types.


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
Issue exists using macOS as well as using Linux at least.
Comment 1 Thorsten Wagner 2019-05-26 20:59:35 UTC
Created attachment 151687 [details]
Screenshot
Comment 2 V Stuart Foote 2019-05-27 08:44:44 UTC
Created attachment 151697 [details]
Sifr icons for Impres display modes toolbox -- current master/6.3.0alpha1+

Those are Colibre icons (Sifr has a fallback to Colibre, right?).  But on Windows build with Sifr icon theme we get the attached. Andreas?
Comment 3 V Stuart Foote 2019-05-27 08:50:00 UTC
Are there Sifr theme icons used for the Impress displaymodes?

BMP_DISPLAYMODE_SLIDE  "sd/res/displaymode_slide.png"
BMP_DISPLAYMODE_OUTLINE "sd/res/displaymode_outline.png"
BMP_DISPLAYMODE_NOTES "sd/res/displaymode_notes.png"
BMP_DISPLAYMODE_SLIDE_SORTER "sd/res/displaymode_slidesorter.png"
BMP_DISPLAYMODE_SLIDE_MASTER "sd/res/displaymode_slidemaster.png"
BMP_DISPLAYMODE_NOTES_MASTER "sd/res/displaymode_notesmaster.png"
BMP_DISPLAYMODE_HANDOUT_MASTER "sd/res/displaymode_handoutmaster.png"
Comment 4 V Stuart Foote 2019-05-27 08:52:29 UTC
Comment on attachment 151697 [details]
Sifr icons for Impres display modes toolbox -- current master/6.3.0alpha1+

these Sifr appropriate icons are shown in Windows build of master/6.3.0alpha1+ Version: 6.3.0.0.alpha1+
Build ID: 4b893906984a4620fda7e1914f0d1ea3416ef42c
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 5 Thorsten Wagner 2019-07-22 10:59:09 UTC
Icons for display modes have been replaced for all icon sets (second icon on the right of attached screenshot 1), but after placing mouse over icon selection outline is too large now. This is not visible on screenshot, but easy to reproduce by placing mouse over icon (at least on macOS).

After changing icon set to verify whether issue occurs with other icon sets too, there are further issues:

(1) LibreOffice crashes (see screenshot 2)

(2) Recovery dialog appears unselected, Text on button "Start" is white although not selected (see screenshot 3)
Comment 6 Thorsten Wagner 2019-07-22 10:59:36 UTC
Created attachment 152933 [details]
Screenshot 1
Comment 7 Thorsten Wagner 2019-07-22 10:59:54 UTC
Created attachment 152934 [details]
Screenshot 2
Comment 8 Thorsten Wagner 2019-07-22 11:00:13 UTC
Created attachment 152935 [details]
Screenshot 3
Comment 9 Thorsten Wagner 2019-08-01 23:05:54 UTC
Since crash during changing icon style is resolved, behaviour is now better visible:

(1) After starting impress from Startcenter wrong icon "Display Views" is displayed as in screenshot 1 independed of icon style.

(2) After changing icon style (without crash now) correct icon "Display Views" is displayed, for Sifr as in Stuart's screenshot.

(3) Closing Impress and starting Impress again causes wrong icon to be displayed again as in screenshot 1.
Comment 10 V Stuart Foote 2019-08-01 23:28:50 UTC
@Tor, do you have a few cycles to look at this missing icon fall back on macOS to maybe tweak early in 6.3.0? 

Thnaks!
Comment 11 Thorsten Wagner 2019-10-17 21:15:13 UTC
Icon seems to be missing in the following icon sets: Sifr, Colibre. Sifr uses Breeze as fallback, Colibre as no sufficient fallback (icon to tall, not from a theme icon set like Breeze, Elementary, Karasa Jaga, Tango).
Comment 12 Commit Notification 2020-02-22 03:09:56 UTC
rizmut committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/fef40fd13ec1739f5308d1ff3bcc2291e7a5d96f

Sifr: Fix for tdf#125510 missing highly visible icons

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2020-02-22 05:48:48 UTC
rizmut committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/f768f8f3b67af5cee39092e4f6f378bee845b3f4

Sifr: Fix for tdf#125510 missing highly visible icons

It will be available in 6.4.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Thorsten Wagner 2020-02-24 00:17:40 UTC
Great work - Sifr becomes more and more usable!

See attached screenshots 4 to 7 to find some remaining issues:

(1) In Writer new Display Views icon is too large (see screenshot 4, red box). Required size is shown in screenshot 5, red box to compare.

(2) In Draw there is an out of bounds icon too (see screenshot 6).

(3) It would be very nice to get rid of Breeze fallbacks. Icons to illustrate password protected files within Startcenter have no Sifr counterparts currently (see screenshot 7).
Comment 15 Thorsten Wagner 2020-02-24 00:18:04 UTC
Created attachment 158123 [details]
Screenshot 4
Comment 16 Thorsten Wagner 2020-02-24 00:18:26 UTC
Created attachment 158124 [details]
Screenshot 5
Comment 17 Thorsten Wagner 2020-02-24 00:18:44 UTC
Created attachment 158125 [details]
Screenshot 6
Comment 18 Thorsten Wagner 2020-02-24 00:19:05 UTC
Created attachment 158126 [details]
Screenshot 7
Comment 19 Rizal Muttaqin 2020-03-29 10:27:48 UTC
(In reply to Thorsten Wagner from comment #14)
> Great work - Sifr becomes more and more usable!
> 
> See attached screenshots 4 to 7 to find some remaining issues:
> 
> (1) In Writer new Display Views icon is too large (see screenshot 4, red
> box). Required size is shown in screenshot 5, red box to compare.

I know some icons use the size just like screenshot 5, but I follow Colibre and Sukapura in this case. If you wish, I can change them to larger size as your request just like in Breeze, elementary and Karasa Jaga. Just wait for the patch.

> (2) In Draw there is an out of bounds icon too (see screenshot 6).
> 

What do you mean with out of bounds? Please file a separate bug report to keep the patch atomic.

> (3) It would be very nice to get rid of Breeze fallbacks. Icons to
> illustrate password protected files within Startcenter have no Sifr
> counterparts currently (see screenshot 7).

I've reported this also in tdf#130898 but we have a blocker: tdf#130936 that prevent me to do the work as if I change them to be monochrome, then the MIME type overlays icons in Start Center become unclear.
Comment 20 Rizal Muttaqin 2020-03-29 10:31:50 UTC
> (3) It would be very nice to get rid of Breeze fallbacks. Icons to
> illustrate password protected files within Startcenter have no Sifr
> counterparts currently (see screenshot 7).

The idea is to set all the icons to be monochrome, but if you wish I could help to  draw some of them first especially for protected files.
Comment 21 Thorsten Wagner 2020-04-01 22:24:56 UTC
(In reply to Rizal Muttaqin from comment #19)
> (In reply to Thorsten Wagner from comment #14)
> > Great work - Sifr becomes more and more usable!
> > 
> > See attached screenshots 4 to 7 to find some remaining issues:
> > 
> > (1) In Writer new Display Views icon is too large (see screenshot 4, red
> > box). Required size is shown in screenshot 5, red box to compare.
> 
> I know some icons use the size just like screenshot 5, but I follow Colibre
> and Sukapura in this case. If you wish, I can change them to larger size as
> your request just like in Breeze, elementary and Karasa Jaga. Just wait for
> the patch.

Indeed icons of Colibre and Sukapura have this issue too. A smaller size as in screenshot 5 is required, because selection rectangle is not drawn completely when moving mouse over.

> > (2) In Draw there is an out of bounds icon too (see screenshot 6).
> > 
> 
> What do you mean with out of bounds? Please file a separate bug report to
> keep the patch atomic.

"Out of bounds" means icons of the same too large size as discussed above. Size is too large to draw selection rectangle completely when moving mouse over.

> > (3) It would be very nice to get rid of Breeze fallbacks. Icons to
> > illustrate password protected files within Startcenter have no Sifr
> > counterparts currently (see screenshot 7).
> 
> I've reported this also in tdf#130898 but we have a blocker: tdf#130936 that
> prevent me to do the work as if I change them to be monochrome, then the
> MIME type overlays icons in Start Center become unclear.
Comment 22 Thorsten Wagner 2020-04-01 22:25:44 UTC
(In reply to Rizal Muttaqin from comment #20)
> > (3) It would be very nice to get rid of Breeze fallbacks. Icons to
> > illustrate password protected files within Startcenter have no Sifr
> > counterparts currently (see screenshot 7).
> 
> The idea is to set all the icons to be monochrome, but if you wish I could
> help to  draw some of them first especially for protected files.

Current build from master contains Sifr icons for protected files now - thank you very much!
Comment 23 Rizal Muttaqin 2020-04-19 09:00:29 UTC
> 
> Indeed icons of Colibre and Sukapura have this issue too. A smaller size as
> in screenshot 5 is required, because selection rectangle is not drawn
> completely when moving mouse over.

 
> "Out of bounds" means icons of the same too large size as discussed above.
> Size is too large to draw selection rectangle completely when moving mouse
> over.


Please file two separate bug reports for these two different requests. We would love to see every patch targets specific report so we can easily avoid conflicted patch when doing back port. This bug report has been renamed to make it clearer what's missing.
Comment 24 Commit Notification 2020-04-19 15:03:37 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/4a670f4284cd2131845ef940d10daedf57014ea4

Sifr: Update Display View icons tdf#125510

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 25 Commit Notification 2020-04-19 22:17:38 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/57fee3e548cc23163c0d6d5c8be63f6a1336cf8a

Sifr: Update Display View icons tdf#125510

It will be available in 6.4.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 26 Thorsten Wagner 2020-04-21 21:28:17 UTC
Thank you very match, icon size is correct now for Sifr - will file two similar issues for Colibre and Sukapura
Comment 27 Rizal Muttaqin 2020-04-21 23:13:27 UTC
(In reply to Thorsten Wagner from comment #26)
> Thank you very match, icon size is correct now for Sifr - will file two
> similar issues for Colibre and Sukapura

And one another bug report for out of bonds Sifr.


I change this bug to RESOLVED FIXED as the bug and the patch are actually exist.
Comment 28 Thorsten Wagner 2020-04-21 23:19:36 UTC
yes, for Sifr there is a remainig icon within Draw toolbar whose size is too large as well